[blfs-support] BLFS 7.10 fonts less clear than in 7.9.

Michael Shell list1 at michaelshell.org
Wed Sep 21 19:09:46 PDT 2016


On Wed, 21 Sep 2016 16:30:57 -0500
rhubarbpieguy at gmail.com wrote:
 
> antialias - Changing the antialias setting from 'true' to 'false' helped 
> significantly.  The fonts are just a touch 'blotchy' but the bold 
> problem is eliminated.  However, if I change /etc/fonts/local.conf to 
> include only an antialias setting the fonts are acceptable.


I'm surprised that a change in fontconfig is causing this. Most of the
time problems in this regard are caused by changes in freetype:

https://www.freetype.org/

Mote the changes they are doing all the time (e.g., 2.6.5 versus 2.7).

I've encountered a lot of freetype woes like what you are seeing
over the years.


Do you see any differences in /etc/fonts/fonts.conf, which is the system
default, for fontconfig? Are you running any of the /etc/fonts/conf.d
stuff in your startup files?

You can try creating copies of the fontconfig files:

cp -a /etc/fonts /etc/fonts-blfs7.9
or
cp -a /etc/fonts /etc/fonts-blfs7.10

and then overwriting a 7.10 /etc/fonts with that of 7.9 and see if that
corrects the problem with everything else being the same. If so, then
fontconfig did indeed change some of its defaults.

What are the two different versions of fontconfig you are using under
7.9 and 7.10?

Looking at the changelogs:

https://www.freedesktop.org/software/fontconfig/release/

The only thing that catches my eye for 2.12.1

https://www.freedesktop.org/software/fontconfig/release/ChangeLog-2.12.1

is at the end:

"Add --with-default-hinting to configure"


Are you sure that you are not running different versions of freetype
as opposed to fontconfig between your 7.9 and 7.10 systems?


  Cheers and thanks,

  Mike




More information about the blfs-support mailing list