[blfs-support] samba-4.4.5 installation failed

Sainadh J jsainadh at ymail.com
Mon Sep 12 01:14:29 PDT 2016


hello,when i try to install samba-4.4.5 i getting the following error :root [ /xc/samba-4.4.5 ]# make install 
WAF_MAKE=1 python ./buildtools/bin/waf install
Waf: Entering directory `/xc/samba-4.4.5/bin'
* creating /etc/samba
* creating /var/lib/samba/private
* creating /var/log/samba
* creating /var/lib/samba/private
* creating /var/lib/samba
* creating /var/lib/samba
* creating /var/cache/samba
* creating /var/lock/samba
/xc/samba-4.4.5/wscript: error: Traceback (most recent call last):
  File "/xc/samba-4.4.5/third_party/waf/wafadmin/Utils.py", line 669, in recurse
    exec(compile(txt, file_path, 'exec'), dc)
  File "/xc/samba-4.4.5/wscript_build", line 46, in <module>
    bld.RECURSE('dynconfig')
  File "./buildtools/wafsamba/samba_utils.py", line 453, in RECURSE
    return ctx.add_subdirs(relpath)
  File "/xc/samba-4.4.5/third_party/waf/wafadmin/Build.py", line 997, in add_subdirs
    self.recurse(dirs, 'build')
  File "/xc/samba-4.4.5/third_party/waf/wafadmin/Utils.py", line 656, in recurse
    f(self)
  File "/xc/samba-4.4.5/dynconfig/wscript", line 426, in build
    bld.INSTALL_DIRS("", "${LOCKDIR} ${PIDDIR} ${SOCKET_DIR}")
  File "./buildtools/wafsamba/wafsamba.py", line 889, in INSTALL_DIRS
    bld.install_dir(os.path.join(destdir, d))
  File "/xc/samba-4.4.5/third_party/waf/wafadmin/Build.py", line 844, in install_dir
    Utils.check_dir(destpath)
  File "/xc/samba-4.4.5/third_party/waf/wafadmin/Utils.py", line 458, in check_dir
    raise WafError("Cannot create the folder '%s' (error: %s)" % (path, e))
WafError: Cannot create the folder '/var/lock/samba' (error: [Errno 2] No such file or directory: '/var/lock/samba')

Makefile:11: recipe for target 'install' failed
make: *** [install] Error 1
make commands works perfect and gives the following output:Waf: Leaving directory `/xc/samba-4.4.5/bin'
'build' finished successfully (10m28.345s)
after that i try to make install above error is occurred.i don't understand what it means i need samba to install gnome-control-center-3.20.1 any suggestion could be appreciated ... i am using blfs-7.10 systemd(stable).
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/blfs-support/attachments/20160912/c4b03671/attachment.html>


More information about the blfs-support mailing list