[blfs-support] vlc player installation error This file requires compiler and library support

Paul Hentschel paul at hpminc.com
Sat Sep 10 07:54:35 PDT 2016


On 09/10/2016 09:38 AM, Sainadh J wrote:
>
>
> On Saturday, 10 September 2016 7:01 PM, akhiezer <lfs65 at cruziero.com> wrote:
>
>
>> Date: Sat, 10 Sep 2016 12:42:06 +0000 (UTC)
>> From: Sainadh J <jsainadh at ymail.com <mailto:jsainadh at ymail.com>>
>> Subject: [blfs-support] vlc player installation error This file requires
>>  compiler and library support
>>
>> Hello,
>> when i tried to install vlc-2.2.4 i getting the following error:
>> stream_filter/httplive.c:975:14: note: 'p_read' was declared here
>>      uint8_t *p_read, *p_begin, *p_end;
>>               ^
>>   CCLD     libhttplive_plugin.la
>>   CC       stream_filter/record.lo
>>   CCLD     librecord_plugin.la
>> make[4]: Leaving directory '/xc/vlc-2.2.4/modules'
>> Making all in audio_filter
>> make[4]: Entering directory '/xc/vlc-2.2.4/modules/audio_filter'
>> make  all-am
>> make[5]: Entering directory '/xc/vlc-2.2.4/modules/audio_filter'
>>   CC       libaudiobargraph_a_plugin_la-audiobargraph_a.lo
>>   CCLD     libaudiobargraph_a_plugin.la
>>   CC       libchorus_flanger_plugin_la-chorus_flanger.lo
>>   CCLD     libchorus_flanger_plugin.la
>>   CC       libcompressor_plugin_la-compressor.lo
>>   CCLD     libcompressor_plugin.la
>>   CC       libequalizer_plugin_la-equalizer.lo
>>   CCLD     libequalizer_plugin.la
>>   CC       libkaraoke_plugin_la-karaoke.lo
>>   CCLD     libkaraoke_plugin.la
>>   CC       libnormvol_plugin_la-normvol.lo
>>   CCLD     libnormvol_plugin.la
>>   CC       libgain_plugin_la-gain.lo
>>   CCLD     libgain_plugin.la
>>   CC       libparam_eq_plugin_la-param_eq.lo
>>   CCLD     libparam_eq_plugin.la
>>   CC       libscaletempo_plugin_la-scaletempo.lo
>>   CCLD     libscaletempo_plugin.la
>>   CXX      spatializer/libspatializer_plugin_la-allpass.lo
>>   CXX      spatializer/libspatializer_plugin_la-comb.lo
>>   CC       spatializer/libspatializer_plugin_la-denormals.lo
>>   CXX      spatializer/libspatializer_plugin_la-revmodel.lo
>>   CXX      spatializer/libspatializer_plugin_la-spatializer.lo
>> In file included from /usr/include/c++/5.3.0/atomic:38:0,
>>                  from ../../include/vlc_atomic.h:221,
>>                  from ../../include/vlc_picture.h:35,
>>                  from ../../include/vlc_filter.h:29,
>>                  from spatializer/spatializer.cpp:43:
>> /usr/include/c++/5.3.0/bits/c++0x_warning.h:32:2: error: #error This
> file requires compiler and library support for the ISO C++ 2011
> standard. This support is currently experimental, and must be enabled
> with the -std=c++11 or -std=gnu++11 compiler options.
>
>
>>Did you use '-std=c++11 or -std=gnu++11 compiler options' ; maybe you
>>can pass them via configure opts or environment vars. (Have not checked
>>book).
>
>
>>  #error This file requires compiler and library support for the \
>>   ^
>> Makefile:2091: recipe for target
> 'spatializer/libspatializer_plugin_la-spatializer.lo' failed
>> make[5]: *** [spatializer/libspatializer_plugin_la-spatializer.lo] Error 1
>> make[5]: Leaving directory '/xc/vlc-2.2.4/modules/audio_filter'
>> Makefile:1557: recipe for target 'all' failed
>> make[4]: *** [all] Error 2
>> make[4]: Leaving directory '/xc/vlc-2.2.4/modules/audio_filter'
>> Makefile:9643: recipe for target 'all-recursive' failed
>> make[3]: *** [all-recursive] Error 1
>> make[3]: Leaving directory '/xc/vlc-2.2.4/modules'
>> Makefile:4516: recipe for target 'all' failed
>> make[2]: *** [all] Error 2
>> make[2]: Leaving directory '/xc/vlc-2.2.4/modules'
>> Makefile:2253: recipe for target 'all-recursive' failed
>> make[1]: *** [all-recursive] Error 1
>> make[1]: Leaving directory '/xc/vlc-2.2.4'
>> Makefile:2137: recipe for target 'all' failed
>> make: *** [all] Error 2
>> i am following BLFS 7.10 and i using Slackware 14.1 64bit as my host
> OS.please guide me through how to resolve this error.
>
>
>
>
>>hth,
>
>
>>akh
>
>
>
>
>
>
>>--
> i am trying like this:
> CFLAGS="-DLUA_COMPAT_5_1" \
> ./configure --prefix=/usr --disable-atmo -std=c++11 &&
> make
> i am getting the error is:
> configure: error: unrecognized option: `-std=c++11'
> when i try with  CFLAGS="-DLUA_COMPAT_5_1" \
> ./configure --prefix=/usr --disable-atmo -std=gnu++11 &&
>
> make
>
> this was also gives the same error:configure: error: unrecognized
> option: `-std=gnu++11'
> is i am trying correct way? if no how can i try?
>
>
>

The instructions in the book work with gcc6. It looks like you are using 
gcc 5.3.0, is that correct? Try starting over and only apply the ffmpeg 
patch, not the gcc6_fixes patch. Also, eliminate the --disable-atmo from 
the configuration and see if that works. In the meantime, I will try to 
find my exact build instructions that I used with gcc 5.3 in case that 
doesn't work. So here are the commands to try for now in a fresh source 
tree:

patch -Np1 -i ../vlc-2.2.4-ffmpeg3-1.patch    &&
CFLAGS="-DLUA_COMPAT_5_1" \
./configure --prefix=/usr &&
make

Paul


More information about the blfs-support mailing list