[blfs-support] xine-lib

Chris Staub chris at beaker67.com
Fri Sep 2 21:25:08 PDT 2016


On 09/02/2016 05:04 PM, Ken Moffat wrote:
> On Mon, Aug 29, 2016 at 09:12:56AM +0100, akhiezer wrote:
>>> Date: Mon, 29 Aug 2016 00:52:35 +0100
>>> From: Ken Moffat <zarniwhoop at ntlworld.com>
>>> Subject: Re: [blfs-support] xine-lib
>>>
>>> OK, thanks for that - I'm now a master of the known universe, and
>>> I've changed both cdrom and dvd to /dev/sr0.  But no joy. At all.
>>
>> Have not got an optical drive hooked up here right now; but here's a
>> coupla things to sanity-check, based on 'historical' gotchas. Apols if
>> some/all covered earlier in thread and have missed it.
>>
>>
>> (Note that you can edit ~/.xine/config as well as, or instead of,
>> going via (g)ui).
>>
>
> OK, got back to this now that most other things have been built and
> tested.  But no joy (now with 7.10).
>>
>> Can you play audio cd when that "settings -> media -> 'device used for
>> CD audio'" = /dev/sr0 ; and cf when = /dev/cdrom .
>>
>
> Yes, at least for /dev/sr0.
>>
>> Check to see if mounting the disc (e.g. mount -t iso9660 /dev/sr0
>> /mnt/tmp) lets you see files/&c in fs-mntpt; and then if xine lets you
>> play the disc from that fs-mntpt instead of the 'raw' /dev/sr0  .
>
> Mounted, but xine tells me it has mp demuxer plugin to handle tha
> mountpoint, same for the audio_ts and video_ts files.
>>
>>
>> Also check, for dvd, that there's nothing unwanted at:
>> ---
>> * settings -> media -> 'default language for DVD playback' (sometimes
>>   defaults to '1')
>>
>
> Seems to be set to en.
>> * settings -> gui -> 'directory a media in dvd device will be mounted'
>>   (sometimes defaults to '/dvd')
>
> That was set to '/dvd', now empty.
>
> But still xine-ui reports
> vo_vdpau: Failed to check vdpau get/put bits native capability :
> VDP_STATUS_NO_IMPLEMENTATION
> libdvdnav: Using dvdnav version 5.0.3
> libdvdread: Could not open /dev/sr0 with libdvdcss.
> libdvdread: Can't open /dev/sr0 for reading
> libdvdnav: vm: failed to open/read the DVD
> libdvdnav: Using dvdnav version 5.0.3
> libdvdread: Could not open /dev/sr0 with libdvdcss.
> libdvdread: Can't open /dev/sr0 for reading
> libdvdnav: vm: failed to open/read the DVD
>
> and the xine windows will not close, had to use -KILL signal.
>
>
>> ---
>>
>>
>>
>> akh
>>
>>
>>
>>
>>
>> --
>> --
>> http://lists.linuxfromscratch.org/listinfo/blfs-support
>> FAQ: http://www.linuxfromscratch.org/blfs/faq.html
>> Unsubscribe: See the above information page
>
I think this may be due to an incompatibility between xine-lib and 
current libdvcss. Try downgrading libdvdcss to 1.2.13 and see if that works.


More information about the blfs-support mailing list