[blfs-support] black screen with plasma5 on intel

Bruce Dubbs bruce.dubbs at gmail.com
Mon Feb 22 09:38:55 PST 2016


Ken Moffat wrote:
> On Mon, Feb 22, 2016 at 10:54:45AM +0000, akhiezer wrote:
>>> Date: Mon, 22 Feb 2016 06:04:04 +0000
>>> From: Ken Moffat <zarniwhoop at ntlworld.com>
>>> Subject: [blfs-support] black screen with plasma5 on intel
>>>
>>> My new build machine is an intel haswell.  On the abortive 7.9-rc1
>>> system (abortive because of the glibc issue) I have ended up by
>>> installing kf5 and plasma, along with sddmR,. to check that upgrading
>>> wayland to 1.10 seems ok.  But when I rebooted to graphical mode,
>>> both icewm and xfce worked fine, but the 'slider' on the 'colourful'
>>> plasma start screen never got beyond about 25% and then I got a
>>> black screen with a mouse pointer.
>>>
>> 	.
>> 	.
>>>
>>> A further suggestion was to give it 5 minutes, in case it eventually
>>> started to work : for the moment I am not willing to wait that long.
>>>
>>> Once I've had some sleep, I'm intending to build 7.9-rc2 from this
>>> system so I'll probably use icewm and get on with that - unless
>>> anybody has any likely fixes ?
>> 	.
>> 	.
>>>
>>
>>
>>   - not even let it run for the duration of you being away doing sleep,
>> or even a shorter-duration other task ? The results may at least help
>> narrow-down what's what.
>>
> I don't like to leave it burning power unnecessarily for hours.
>
> Gave it a try now -
>
> The splash screen fades to blak after about 35 seconds, then about 5
> minutes from logging in I get a message starting "The screen locker
> is broken and unlocking is not possible anymore." and telling me to
> login on a VT and use 'loginctl unlock-sessions' before switching
> back to the running session.
>
> I do not, of course, have loginctl.
>
> The full message can be seen at
> https://github.com/KDE/kscreenlocker/blob/master/abstractlocker.cpp
>
> it comes from the kde screenlocker daemon, apparently triggered by
> m_greeterFailure.  So the greeter failed - I think I had already
> guessed that.  No idea where to look, I'll put this aside.

I am going to start X today.  I'll try kf5 and plasma next, but there are 
a lot of prerequisites.  The problem I had earlier with plasma was that it 
did not find the appropriate javascript modules.  Hence the code on the 
plasma page:

cd $KF5_PREFIX/share/plasma/plasmoids

for j in $(find -name \*.js); do
   as_root ln -sfv ../code/$(basename $j) $(dirname $j)/../ui/
done

   -- Bruce




More information about the blfs-support mailing list