[blfs-support] [Clfs-support] Hexchat problems

Bruce Dubbs bruce.dubbs at gmail.com
Tue Dec 27 20:58:36 PST 2016


Roger Koehler wrote:
> On Tue, Dec 27, 2016 at 9:13 PM, Bruce Dubbs <bruce.dubbs at gmail.com> wrote:
>> Roger Koehler wrote:
>>>
>>> On Tue, Dec 27, 2016 at 9:57 AM, Martin Ward
>>> <macros_the_black at ntlworld.com> wrote:
>>>>
>>>> Gentoo has a patch for this methinks
>>>>
>>>> https://gitweb.gentoo.org/repo/gentoo.git/tree/net-irc/hexchat/files
>>>>
>>>> hexchat-2.12.2-configure.ac-remove-werror.patch
>>>>
>>>> autoreconf -fiv, should then fix it
>>>
>>>
>>> I appreciate the help, Martin. Unfortunately, I'm still getting the same
>>> error:
>>>
>>> autoreconf: Entering directory `.'
>>> autoreconf: configure.ac: not using Gettext
>>> autoreconf: running: aclocal --force -I m4
>>> configure.ac:19: error: macro AX_APPEND_COMPILE_FLAGS is not defined.
>>> Is autoconf-archive installed?
>>> configure.ac:17: HEX_CHECK_MACRO is expanded from...
>>> configure.ac:19: the top level
>>> autom4te: /usr/bin/m4 failed with exit status: 1
>>> aclocal: error: echo failed with exit status: 1
>>> autoreconf: aclocal failed with exit status: 1
>>>
>>> I'll cc blfs-support. From BLFS book change log:
>>>
>>> * December 12th, 2016
>>>             + [bdubbs] - Update to hexchat-2.12.4. Fixes #8635.
>>>
>>> Does not work for me using the latest development version of LFS
>>> (vmlinuz-4.9-lfs-SVN-20161221) with all required and recommended BLFS
>>> dependencies.
>>
>>
>> hexchat is pretty simple.  I do not know why you are using a patch.  All you
>> should need is:
>>
>> ./configure --prefix=/usr
>> make
>> (as root) make install
>>
>> I put my log at
>> http://anduin.linuxfromscratch.org/~bdubbs/files/hexchat-2.12.4.log.  See if
>> you can spot any differences from what you have.
>
> I'm using a later version of Glib and it is complaining about
> autoconf-archive not being installed.  My log is on the left:
>
> < checking for GLIB - version >= 2.34.0... yes (version 2.50.2)
> ---
>> checking for GLIB - version >= 2.34.0... yes (version 2.50.0)
> 259,267c260,889
> < make[1]: Entering directory '/sources/hexchat/hexchat-2.12.4'
> < CDPATH="${ZSH_VERSION+.}:" && cd . && /bin/sh
> /sources/hexchat/hexchat-2.12.4/build-aux/missing aclocal-1.15 -I m4
> < configure.ac:19: error: macro AX_APPEND_COMPILE_FLAGS is not
> defined. Is autoconf-archive installed?
> < configure.ac:17: HEX_CHECK_MACRO is expanded from...
> < configure.ac:19: the top level
> < autom4te: /usr/bin/m4 failed with exit status: 1
> < aclocal-1.15: error: echo failed with exit status: 1
> < make[1]: *** [Makefile:464: aclocal.m4] Error 1
> < make[1]: Leaving directory '/sources/hexchat/hexchat-2.12.4'
> ---
>> (CDPATH="${ZSH_VERSION+.}:" && cd . && /bin/sh /tmp/hexchat/hexchat-2.12.4/build-aux/missing autoheader)
>> rm -f stamp-h1
>> touch config.h.in
>> cd . && /bin/sh ./config.status config.h
>> config.status: creating config.h

I just got back from a trip and have not set up all my systems yet.  I can 
do that tomorrow, but in the meantime, I see AX_APPEND_COMPILE_FLAGS is 
defined in hexchat-2.12.4/aclocal.m4:

AC_DEFUN([AX_APPEND_COMPILE_FLAGS],
[AX_REQUIRE_DEFINED([AX_CHECK_COMPILE_FLAG])
AX_REQUIRE_DEFINED([AX_APPEND_FLAG])
for flag in $1; do
   AX_CHECK_COMPILE_FLAG([$flag], [AX_APPEND_FLAG([$flag], [$2])], [], 
[$3], [$4])
done
])dnl AX_APPEND_COMPILE_FLAGS

But why is autoreconf called at all?  It should not be needed.  I admit 
autoreconf fails for me as above.  It looks like the problem is with 
hexchat's configure.ac as AX_APPEND_COMPILE_FLAGS is used before it is 
defined.  It does look like they want autoconf-archive to be installed:

HEX_CHECK_MACRO([AX_APPEND_COMPILE_FLAGS], [autoconf-archive])

BLFS does not need autoconf-archive, so we don't install it.

http://mirror.easthsia.com/gnu/autoconf-archive/autoconf-archive-2016.09.16.tar.xz

   -- Bruce




   -- Bruce




More information about the blfs-support mailing list