[blfs-support] GPM-1.20.7 in BLFS 7.8 in a Virtualbox 4.3.28 instance on Mac OS X Yosemite 10.10.5 host

Niels Terp nielsterp at comhem.se
Wed Oct 7 00:49:07 PDT 2015


Hi,

Could this be a kernel issue ?

Since long I have had the same package included in my setup-scripts. But after I have migrated to kernel 4x, this has not been working at all in my installation. It is the exact same package, it compiles with no errors - but it doesn't work :-(

I have followed the "standard way" of make mrproper, taken my old config file and doing make oldconfig. The only thing I have not tried is to revert to kernel 3.x Maybe I will try that soon.

Cheers 

Niels

-----Oprindelig meddelelse-----
Fra: blfs-support [mailto:blfs-support-bounces at lists.linuxfromscratch.org] På vegne af Will Senn
Sendt: 6. oktober 2015 05:17
Til: blfs-support at lists.linuxfromscratch.org
Emne: [blfs-support] GPM-1.20.7 in BLFS 7.8 in a Virtualbox 4.3.28 instance on Mac OS X Yosemite 10.10.5 host

Hi,

I have successfully completed the LFS build and have added dhcpcd, openssl, openssh, wget, and lynx successfully - now I am trying to get GPM working. I have followed the BLFS book instructions, but I don't seem to be able to get the mouse to work in the console.

Here are some of the things I have tried:
recompiling the kernel with psaux support

modifying /etc/sysconfig/mouse and rebooting after each edit MDEVICE="/dev/psaux"
MDEVICE="/dev/mice"
MDEVICE="/dev/mouse0" # it was present in /dev so why not?

PROTOCOL="imps2"
PROTOCOL="ps2"

changing the VM settings from the default USB Pointing device to PS/2.

I admit to not truly understanding the interaction between the VM, the host and the client, so if it's patently obvious what's wrong, please be kind. I haven't been able to find much useful information about how to test this. I am hoping to be able to copy/cut/paste from the command line using the mouse without having to resort to using a mac terminal and ssh. I don't have X or virtualbox extensions installed.

Has anyone been able to configure GPM to work in the lfs console in a virtual box VM?
Do you have some troubleshooting tips?
Is there a test command I can use that will provide an error message of some sort?


Thanks,

Will


--
http://lists.linuxfromscratch.org/listinfo/blfs-support
FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page



More information about the blfs-support mailing list