[blfs-support] Correction to OpenLDAP wiki

Quanah Gibson-Mount quanah at zimbra.com
Mon Mar 23 13:42:53 PDT 2015


Hello,

The wiki located here:

<http://www.linuxfromscratch.org/blfs/view/svn/server/openldap.html>

needs some updating.  It specifically recommends that people apply patches 
that should be not used.  Specifically, it patches OpenLDAP to build 
against BDB 6.x.  BDB 6.x have a hostile licensing change made by Oracle 
that makes BDB unusable with OpenLDAP.  Having people patch their OpenLDAP 
build to support BDB 6 means that they are then liable to a visit from 
Oracle's lawyers and general extortion to feed the Oracle coffers.  There 
is a reason the OpenLDAP foundation removes support for BDB 6.x and later.

The default backend for OpenLDAP is LMDB, and is what should be used and 
recommended by linux from scratch.

Thanks for your prompt attention to the issue.

Thanks,
Quanah

--

Quanah Gibson-Mount
Platform Architect
Zimbra, Inc.
--------------------
Zimbra ::  the leader in open source messaging and collaboration


More information about the blfs-support mailing list