[blfs-support] WebKitGTK+-2.4.9 really requires Ruby?

Michael Shell list1 at michaelshell.org
Mon Jul 20 01:41:10 PDT 2015



For the older WebKitGTK+-2.4.9 (assume a GTK+2 build here):

http://www.linuxfromscratch.org/blfs/view/svn/x/webkitgtk2.html

Ruby-2.2.2 is listed as a required dependency. But, I can't seem
to find this requirement mentioned anywhere except on LFS:

https://lists.webkit.org/pipermail/webkit-gtk/2015-May/002357.html

Is Ruby really required, or is this just for those who intend to
run Gnome? What later uses the Ruby WebKitGTK+ bindings?

Obviously not a big deal either way given that Ruby itself doesn't
have any significant dependencies.



  Thanks in advance,

  Mike Shell


More information about the blfs-support mailing list