[blfs-support] LFS-7.6-systemd Cairo-1.12.16 build issue

Wayne Blaszczyk wblaszcz at bigpond.net.au
Sat Sep 27 17:42:24 PDT 2014


On 28/09/14 09:48, Armin K. wrote:
> On 09/28/2014 12:41 AM, Wayne Blaszczyk wrote:
>> Hi,
>>
>> Just completed building LFS-7.6-systemd with no issues.
>> A big thanks to everyone involved. I'm now building the rest of the
>> system but got stuck at this point with the following error:
>>
>>
>>
>> make[4]: Entering directory '/sources/cairo-1.12.16/util/cairo-sphinx'
>>   CCLD   cairo-sphinx
>> /tmp/ccg1kVON.ltrans0.ltrans.o: In function `do_client':
>> /sources/cairo-1.12.16/util/cairo-sphinx/sphinx.c:1376: undefined
>> reference to `cairo_boilerplate_get_target_by_name'
>> /sources/cairo-1.12.16/util/cairo-sphinx/sphinx.c:1389: undefined
>> reference to `cairo_boilerplate_xmalloc'
>> /tmp/ccg1kVON.ltrans0.ltrans.o: In function `clients_init':
>> /sources/cairo-1.12.16/util/cairo-sphinx/sphinx.c:271: undefined
>> reference to `cairo_boilerplate_xmalloc'
>> /tmp/ccg1kVON.ltrans0.ltrans.o: In function `do_server':
>> /sources/cairo-1.12.16/util/cairo-sphinx/sphinx.c:1176: undefined
>> reference to `cairo_boilerplate_xmalloc'
>> /tmp/ccg1kVON.ltrans0.ltrans.o: In function `clients_add_command':
>> /sources/cairo-1.12.16/util/cairo-sphinx/sphinx.c:307: undefined
>> reference to `cairo_boilerplate_xmalloc'
>> /sources/cairo-1.12.16/util/cairo-sphinx/sphinx.c:318: undefined
>> reference to `cairo_boilerplate_xmalloc'
>> /tmp/ccg1kVON.ltrans0.ltrans.o:/sources/cairo-1.12.16/util/cairo-sphinx/sphinx.c:331:
>> more undefined references to `cairo_boilerplate_xmalloc' follow
>> /tmp/ccg1kVON.ltrans0.ltrans.o: In function `do_server':
>> /sources/cairo-1.12.16/util/cairo-sphinx/sphinx.c:1232: undefined
>> reference to `cairo_boilerplate_xrealloc'
>> /tmp/ccg1kVON.ltrans0.ltrans.o: In function `clients_send_trace.isra.5':
>> /sources/cairo-1.12.16/util/cairo-sphinx/sphinx.c:803: undefined
>> reference to `cairo_boilerplate_xrealloc'
>> /tmp/ccg1kVON.ltrans0.ltrans.o: In function `do_server':
>> /sources/cairo-1.12.16/util/cairo-sphinx/sphinx.c:295: undefined
>> reference to `cairo_boilerplate_xrealloc'
>> /tmp/ccg1kVON.ltrans0.ltrans.o: In function `do_client':
>> /sources/cairo-1.12.16/util/cairo-sphinx/sphinx.c:1433: undefined
>> reference to `cairo_boilerplate_xrealloc'
>> /tmp/ccg1kVON.ltrans1.ltrans.o: In function `_surface_create.lto_priv.8':
>> /sources/cairo-1.12.16/util/cairo-sphinx/sphinx.c:984: undefined
>> reference to `cairo_boilerplate_xmalloc'
>> /tmp/ccg1kVON.ltrans1.ltrans.o: In function `get_surface_size':
>> /sources/cairo-1.12.16/util/cairo-sphinx/sphinx.c:894: undefined
>> reference to `cairo_boilerplate_xmalloc'
>> /tmp/ccg1kVON.ltrans1.ltrans.o: In function `_context_create.lto_priv.9':
>> /sources/cairo-1.12.16/util/cairo-sphinx/sphinx.c:1001: undefined
>> reference to `cairo_boilerplate_xmalloc'
>> /tmp/ccg1kVON.ltrans1.ltrans.o: In function `recorder.lto_priv.11':
>> /sources/cairo-1.12.16/util/cairo-sphinx/sphinx.c:1080: undefined
>> reference to `cairo_boilerplate_xmalloc'
>> /sources/cairo-1.12.16/util/cairo-sphinx/sphinx.c:1113: undefined
>> reference to `cairo_boilerplate_xrealloc'
>> collect2: error: ld returned 1 exit status
>> Makefile:527: recipe for target 'cairo-sphinx' failed
>> make[4]: *** [cairo-sphinx] Error 1
>> make[4]: Leaving directory '/sources/cairo-1.12.16/util/cairo-sphinx'
>> Makefile:706: recipe for target 'all-recursive' failed
>> make[3]: *** [all-recursive] Error 1
>> make[3]: Leaving directory '/sources/cairo-1.12.16/util'
>> Makefile:498: recipe for target 'all' failed
>> make[2]: *** [all] Error 2
>> make[2]: Leaving directory '/sources/cairo-1.12.16/util'
>> Makefile:632: recipe for target 'all-recursive' failed
>> make[1]: *** [all-recursive] Error 1
>> make[1]: Leaving directory '/sources/cairo-1.12.16'
>> Makefile:483: recipe for target 'all' failed
>> make: *** [all] Error 2
>>
>>
>> It seems to be the same as https://bugs.archlinux.org/task/40313
>> It looks like they resolved it by disabling LTO. But the issue is that
>> --disable-lto is not a recognized option. Arch is using 1.13.1.
>>
>> Any ideas?
>>
>> Thanks,
>> Wayne.
>>
> 
> CFLAGS are modified to include -ffat-lto-objects, which should fix that.
> If it still fails, change it to -fno-lto.
> 
> 
> 

I accidentally had the CFLAGS on a separate line before the configure!
Sorry about the noise.

Wayne.


More information about the blfs-support mailing list