[blfs-support] Trouble Installing GPM

Alan Feuerbacher alanf00 at comcast.net
Tue Sep 9 04:44:45 PDT 2014


On 9/8/2014 8:40 AM, David Brodie wrote:
> On 08/09/14 06:26, Alan Feuerbacher wrote:
>> Howdy,
>>
>> I just finished installing a basic LFS system, and am trying to install
>> GPM-1.20.7. Unfortunately, the first line of the BLFS book (Version
>> 2014-09-06) instructions fails:
>>
>> ./autogen.sh
>>
>> I get an error message:
>>
>> configure.ac:43:error: possibly undefined macro: AC_PROG_LIBTOOL . . .
>>
>> I've searched online and found a few suggestions to install libtool to
>> correct this problem (always applies to regular distros), but libtool is
>> already a part of the basic LFS installation. So I recompiled libtool
>> from scratch, as well as GPM, but saw no change to the error message.
>>
>> I'm completely at a loss here.
>>
>> Last year I installed an earlier version of LFS and BLFS, which used the
>> same version of GPM (1.20.7) as is being used here. So it's surprising
>> that such an apparently basic error is occurring this time around.
>>
>> Alan
>
> autogen is quite sensitive as to the version of 'autoconf' you are
> using, so I would check that you have the current version (2.69)
> installed in your LFS system, and that you are building gpm either
> inside an LFS change-root, or from the live LFS system.
>
> David

Yes, I have that version of autoconf (every software package is from LFS 
Version SVN-20140831, download via the wget-list at the same time). I 
definitely used the LFS change-root environment.

Any other ideas?

Alan


More information about the blfs-support mailing list