[blfs-support] Assign USB device to a Guest VM - permission problem

Eugen Barticel eugenbart66 at gmail.com
Sat Oct 25 04:03:35 PDT 2014


I think you should add user to vbox or vboxuser groups as well, if you
didn't already.

On Sat, Oct 25, 2014 at 5:40 AM, Cliff McDiarmid <cliffhanger at gardener.com>
wrote:

> Hi
>
> Can anyone help here with a VM problem?
>
> I'm using Qemu, with KVM, on LFS 7.5(with systemd)to run a virtual machine
> and need to assign a usb device(gps) from the host to guest.
> If I run the VM from root, with the necessary arguments, then everything
> works fine.
>
> But I want to run it from the user.  And here is where the problem lies.
> I've included a udev rule for the device in the host like this:
>
>
> #Prolific Technology GPS
> SUBSYSTEMS=="usb", ATTRS{idVendor}=="067b", ATTRS{idProduct}=="2303",
> MODE="0644", GROUP="usb"
>
> I've made sure the user is part of the 'usb' group, but I still get the
> following error:
>
> 'libusbx: error [_get_usbfs_fd] libusbx couldn't open USB device
> /dev/bus/usb/003/003:
> Permission denied libusbx: error [_get_usbfs_fd] libusbx requires write
> access to USB device nodes'
>
> I've tried changing the 'mode', I shouldn't have to, but this makes no
> difference.
>
> Any help appreciated.
>
> MAC
> --
> http://lists.linuxfromscratch.org/listinfo/blfs-support
> FAQ: http://www.linuxfromscratch.org/blfs/faq.html
> Unsubscribe: See the above information page
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/blfs-support/attachments/20141025/3f40e304/attachment.html>


More information about the blfs-support mailing list