[blfs-support] vlc - anybody got encoded DVDs to play properly ?

Bruce Dubbs bruce.dubbs at gmail.com
Wed Jun 18 16:17:34 PDT 2014


Ken Moffat wrote:
> On Wed, Jun 18, 2014 at 04:00:42PM -0500, Bruce Dubbs wrote:
>>
>> Video problem?  DVD driver problem?  I tested on my i7 with i915 video
>> drivers.  It's a pretty new (less than 2 months old) system.
>>
>>    -- Bruce
>
>   Both are possible, but I have seen the same issue for several years
> and multiple hardware variants.  For me, the i915 on SandyBridge
> (with the extra drivers which are in BLFS - I'm thinking of libva or
> whatever it is called) - works well in every other usage, so I will
> be surprised if it contributes to this problem.  On AMD I have had
> video problems on recent -rc kernels, but gabriele's earlier response
> says that he too has had problems with (he thought) vlc-2 :  I am
> pretty sure that my problems started before that.
>
>   I suspect that I had this problem even before I was using KMS (so,
> the radeon driver with userspace mode settings).  And for the DVD
> drive, it is whatever the kernel provides - in the beginning, that
> was probably /dev/hdX with the old driver, but for several years it
> has been the libata driver on /dev/sr0.

I know you do special things.  All I did was follow BLFS.  Did you say 
that it works fine if you transfer the DVD to hard disk?  If so, then 
the problem is almost certainly a dvd driver/hw issue.  I have:

[    2.183354] ata1.00: configured for UDMA/100
[    2.188946] scsi 0:0:0:0: CD-ROM TSSTcorp CDDVDW SU-208FB  TF01 PQ: 0 
ANSI: 5
[    2.205397] sr0: scsi3-mmc drive: 24x/24x writer dvd-ram cd/rw 
xa/form2 cdda tray
[    2.206277] cdrom: Uniform CD-ROM driver Revision: 3.20
[    2.207283] sr 0:0:0:0: Attached scsi CD-ROM sr0
[    2.207343] sr 0:0:0:0: Attached scsi generic sg0 type 5

#
# SCSI device support
#
CONFIG_SCSI_MOD=y
# CONFIG_RAID_ATTRS is not set
CONFIG_SCSI=y
CONFIG_SCSI_DMA=y
# CONFIG_SCSI_TGT is not set
# CONFIG_SCSI_NETLINK is not set
CONFIG_SCSI_PROC_FS=y

#
# SCSI support type (disk, tape, CD-ROM)
#
CONFIG_BLK_DEV_SD=y
# CONFIG_CHR_DEV_ST is not set
# CONFIG_CHR_DEV_OSST is not set
CONFIG_BLK_DEV_SR=y
CONFIG_BLK_DEV_SR_VENDOR=y
CONFIG_CHR_DEV_SG=y
# CONFIG_CHR_DEV_SCH is not set
# CONFIG_SCSI_MULTI_LUN is not set
CONFIG_SCSI_CONSTANTS=y
# CONFIG_SCSI_LOGGING is not set
# CONFIG_SCSI_SCAN_ASYNC is not set

#
# SCSI Transports
#
CONFIG_SCSI_SPI_ATTRS=y
...

CONFIG_ATA=y
# CONFIG_ATA_NONSTANDARD is not set
CONFIG_ATA_VERBOSE_ERROR=y
CONFIG_ATA_ACPI=y
# CONFIG_SATA_ZPODD is not set
CONFIG_SATA_PMP=y

#
# Controllers with non-SFF native interface
#
CONFIG_SATA_AHCI=y
# CONFIG_SATA_AHCI_PLATFORM is not set
# CONFIG_SATA_INIC162X is not set
# CONFIG_SATA_ACARD_AHCI is not set
# CONFIG_SATA_SIL24 is not set
CONFIG_ATA_SFF=y

#
# SFF controllers with custom DMA interface
#
# CONFIG_PDC_ADMA is not set
# CONFIG_SATA_QSTOR is not set
# CONFIG_SATA_SX4 is not set
CONFIG_ATA_BMDMA=y

#
# SATA SFF controllers with BMDMA
#
CONFIG_ATA_PIIX=y



   -- Bruce


More information about the blfs-support mailing list