[blfs-support] PHP-5.5.4 and MySQLi - BLFS Book

Bruce Dubbs bruce.dubbs at gmail.com
Fri Sep 27 08:18:18 PDT 2013


Dr.-Ing. Edgar Alwers wrote:
> Hi Bruce,
>
> the "conf.sample.inc.php" configuration file for phpMyAdmin defines "mysqli"
> as default :

> $cfg['Servers'][$i]['extension'] = 'mysqli'
>
> http://www.php.net/manual/en/mysqli.overview.php#mysqli.overview.mysqlnd
> quoting this manual:
> "If you are using MySQL versions 4.1.3 or later it is strongly recommended
> that you use the mysqli extension instead."
>
> I am wondering, if ./configure  PHP-5.5.4  ( Book § 13) should not include the
> statement

> "  --with-mysqli=mysqlnd \"

> This could save debugging time. What do you think ?

My version is slightly out of date m(5.5.3), but I have:

...
--with-mysqli \
--with-mysql  \
...

in my script.

I need the older --with-mysql for some legacy programs.  We don't 
specify a DB for php because the many DBes mentioned are completely 
optional.

We do have a note with a pointer to 
http://anduin.linuxfromscratch.org/files/BLFS/svn/php_configure.txt.  I 
did update that.  We may want to add a note to that also.

    -- Bruce




More information about the blfs-support mailing list