[blfs-support] Fwd: samba-4.0.9 wont compile

Bruce Dubbs bruce.dubbs at gmail.com
Wed Sep 11 08:03:44 PDT 2013


lux-integ wrote:

> [ 492/2709] Compiling dynconfig/dynconfig.c
> ../lib/param/loadparm.c: In function 'loadparm_init':
> ../lib/param/loadparm.c:2145:20: error: 'SAMBA_VERSION_STRING' undeclared
> (first use in this function)
>          "Samba %s", SAMBA_VERSION_STRING);
>                      ^
> ../lib/param/loadparm.c:2145:20: note: each undeclared identifier is reported
> only once for each function it appears in
> [ 493/2709] Compiling lib/util/charset/iconv.c
> Waf: Leaving directory `/home/linteg/samba-4.0.9/bin'
> Build failed:  -> task failed (err #1):
> 	{task: cc loadparm.c -> loadparm_7.o}
> #-----------------------------------------------------------

A grep of the source shows SAMBA_VERSION_STRING being defined by a 
python program.  I don't understand how you configured, as you fail at 
[ 492/2709], yet my build shows

[ 742/3897] Compiling dynconfig/dynconfig.c

with no errors.  Do you have python installed?  Perhaps we have omitted 
a required dependency of python.

   -- Bruce



More information about the blfs-support mailing list