[blfs-support] Cannot Print document using HP Printer

Sirsendu Roy xairoy at yahoo.com
Sun Sep 8 05:23:59 PDT 2013


Hi,
Ok, Let's analyze the matter systematically !!!!
 I have deleted everything using cups admin, job queue, printers. 
According to BLFS cups installation manual, "There is a conflict between the Cups libusb backend and the usblp kernel driver. If you want to use Cups with libusb, do not enable USB Printer support in your kernel"

I have enabled the USB Printer support option in the kernel (As I have compiled the kernel before I have installed the cups module !!!). So I have used the --disable-libusswitch when compiling cups. 
Now when I try to use the cups front end using the web browser and try to find the printer- it cannot not find the printer. 
Do you think this is normal  as I have not compiled cups with libusb support? if yes, then I need to add the printer manually, istn't it? Which I tried to do but I do not know what I should write : the options are :
http://hostname:631/ipp/ 
http://hostname:631/ipp/port1
 ipp://hostname/ipp/ 
ipp://hostname/ipp/port1 
lpd://hostname/queue 
socket://hostname 
socket://hostname:9100

I have tried http://hostname:631/ipp/, ipp://hostname/ipp/ and lpd://hostname/queuebut it didn't work !!!! it is saying not such hostname when trying to print a test page. 
It will be nice if you can provide me a step by step debug instruction
Thanks for your help.
Reagrds,
Roy
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/blfs-support/attachments/20130908/fa2d2b15/attachment.html>


More information about the blfs-support mailing list