[blfs-support] Wireless errors

spiky martynvidler at aol.com
Sun Mar 17 14:43:46 PDT 2013


On 17/03/13 21:28, Armin K. wrote:
> On 03/17/2013 10:27 PM, spiky wrote:
>> On 17/03/13 21:20, Armin K. wrote:
>>> On 03/17/2013 09:44 PM, spiky wrote:
>>>> Hi
>>>>
>>>> I having trouble with usb wireless, I have installed the drivers for the
>>>> device
>>>> belkin **F5D7050 Wireless G Adapter v3000 [Ralink RT2571W]*
>>>> * The kernel has the rt73usb=y
>>>>
>>>> The error is
>>>> root [ /etc/sysconfig ]# ifup wlan0
>>>>          Bringing up the wlan0 interface...
>>>>       *  Adding IPv4 address 192.168.0.200 to the wlan0 interface... [  OK  ]
>>>> RTNETLINK answers: No such file or directory
>>>>
>>>>      *** ay already setup; skipping. [ WARN ]
>>>>
>>>> I have tried this with kernel 3.8.3 which is all working and I have
>>>> tried on kernel3.7.10.
>>>> My only thought is there is something Networking "protocols" I have missed.
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>> I am unsure what's the error but did you install firmware? I rememmber
>>> ralink cards needed firmware to load properly. Also, yre you sure that
>>> your network card is called wlan0? udev now renames it to strange names.
>> I have tried it with the firmware in /lib/firmware I will try it again.
>> To install the firmware I just opened the file and copied rt73.bin to
>> /lib/firmware Hope that was correct
>>
>> Also iwconfig returns
>> wlan0     no wireless extensions.
>>
>> sit0      no wireless extensions.
>>
>> lo        no wireless extensions.
>>
>> eth0      no wireless extensions.
>> So i,m taking it as wlan0
>>
> If you have built your wireless driver into kernel, then you have to
> built firmware into kernel, too. If not, udev should load it when the
> module is loaded - you should get "firmware not found" or no error if
> not/if suceeded.
I have this from config

#
# Generic Driver Options
#
CONFIG_UEVENT_HELPER_PATH="/sbin/hotplug"
CONFIG_DEVTMPFS=y
CONFIG_DEVTMPFS_MOUNT=y
CONFIG_STANDALONE=y
CONFIG_PREVENT_FIRMWARE_BUILD=y  <<<<<
CONFIG_FW_LOADER=y
CONFIG_FIRMWARE_IN_KERNEL=y <<<<<
CONFIG_EXTRA_FIRMWARE=""
# CONFIG_DEBUG_DRIVER is not set
CONFIG_DEBUG_DEVRES=y
# CONFIG_SYS_HYPERVISOR is not set
# CONFIG_GENERIC_CPU_DEVICES is not set
CONFIG_DMA_SHARED_BUFFER=y
# CONFIG_CMA is not set




More information about the blfs-support mailing list