[blfs-support] System Will Not Mount One of Three Disks

Feuerbacher, Alan AFeuerbacher at ALLEGROMICRO.com
Tue Oct 30 09:31:24 PDT 2012


Armin K. wrote:

> > However, I want to access the Fedora and Debian filesystems from LFS,
> and so, in addition to the normal stuff in /etc/fstab, I have these two
> lines at the very end (I'm writing this from work and can't remember
> exactly what's in the file):
> >
> > /dev/sda /fedora ext4 defaults 0 0
> > /dev/sdb /debian ext3 defaults 0 0

> > Anyway, if I keep only the /debian line, it gets mounted properly and
> I can get to that filesystem. But if I keep only the /fedora line, it
> does not get mounted and I see a "FAIL" message something like "cannot
> mount /fedora; does not exist".
> >
> > I've tried several variations like using "/mnt/fedora" instead
> "/fedora" with no success.

> You need to mount partitions, not drives and that means:
> 
> /dev/sda is node of drive.
> /dev/sda1 is node of the first partition of the drive.
> 
> /dev/sda1 can be mounted, /dev/sda can't.

Ok. However, I've tried that. I've tried using /dev/sda1 and /dev/sda2. Fedora split up the hard disk into two partitions: /dev/sda1 containing /boot and /dev/sda2 containing / (at least, that's what I more or less remember doing). I'll try Bruce's suggestions when I get home tonight.

Alan



More information about the blfs-support mailing list