[blfs-support] Problem and solution of sound issue with GNOME

Armin K. krejzi at email.com
Sat Oct 6 09:22:40 PDT 2012


On 06.10.2012 17:49, Lars Bamberger wrote:
>>
>> I don't quite understand what do you mean by "updated some
>> packages". If you upgraded some packages from 3.4 to 3.6, then I
>> guess nothing works because 3.6 components use GStreamer 1.0 which is
>> incompatible with GStreamer 0.10 (All GNOME components from 3.6 use
>> 1.0).
>
> Indeed, I was upgrading GNOME to version 3.6 (packages listed in the
> book under Platform and Desktop) and also installing GStreamer-1.0 (but
> keeping GStreamer-0.10.36). I wrote "some packages" because I don't know
> which package _exactly_ puts "autoaudiosink" as a default into the GNOME
> settings and at what point sound stopped working.
>

I tought that you were saying something about GNOME Volume Control being 
broken ...

> I only noticed when a fresh installation of rhythmbox-2.98 (not in the
> book) didn't work until after the GNOME packages were installed.
> rhythmbox-2.98 uses GStreamer-0.10, not 1.0. Other applications work
> just fine also, for example mplayer which uses ALSA on my system.
>

Just a warning, if you manage to upgrade WebKit to 1.10.0 and you want 
to use rhythmbox, don't use gstreamer 0.11 switch because it will break 
rhythmbox (I use rhythmbox git checkout that has been ported to 
gstreamer 0.11/1.0 that works fine)

> If, and only if the instructions in the book put 'autoaudiosink' into
> the GNOME preferences AND that does not work for others, this should be
> addressed. Otherwise it's just a coincidence on my system.
> Unfortunately, I don't have an idea on how to isolate this would-be problem.
>

I have GStreamer 1.0 and 0.10 installed and everything worked perfectly 
here. But, I did a clean install.

> I can find a default definition of autoaudiosink in
> /etc/gconf/schemas/gstreamer-0.10.schemas which is owned by
> gst-plugins-good-0.10.31 and also in
> /etc/gconf/gconf.xml.defaults/%gconf-tree.xml which is touched by a
> large amount of packages. It could be that 'autoaudiosink' does work,
> but only if there is only one version of GStreamer and friends
> installed. (I have GStreamer 0.10 and 1.0 installed.) So really, I can't
> tell what causes this, I can only tell you that I had a problem and how
> I fixed it in the hopes that this may be of some use to others.
>
> Cheers mate!
> Lars
>
>




More information about the blfs-support mailing list