[blfs-support] Errors during Xorg Configuration

Cory Cline Cory at ClineCreations.net
Fri Oct 5 11:08:34 PDT 2012


On Fri, Oct 5, 2012 at 1:03 PM, Bruce Dubbs <bruce.dubbs at gmail.com> wrote:
> Cory Cline wrote:
>> On Fri, Oct 5, 2012 at 12:22 PM, Bruce Dubbs <bruce.dubbs at gmail.com> wrote:
>>> Cory Cline wrote:
>>>
>>>> I ran "sh file.sh | grep error" (file.sh is
>>>> the name of the for script.  I ran this outside of the bash -e so
>>>> that I could see where the error
>>>> was coming in.  It seems that it is erroring on the first commented
>>>> line in my proto-7.7.md5 script.  Is there any reason that it would
>>>> ignore the #?
>>>
>>> Paste the script.
>
>>
>> cat > proto-7.7.md5 << "EOF"
>> #c1d50749c3ac5215a1a9425818e856c1  applewmproto-1.4.2.tar.bz2
>
> That's not a script, it's a list of md5sums.  The # means that the line
> is commented out.  The grep -v '^#' skips the line.  If you are trying
> to run that as a script, then of course it will fail.
>
>    -- Bruce
>
> --
Ok.  There is a misunderstanding here.  The script I am running is the
for loop in a .sh file.  The for loop references a file named
proto-7.7.md5 which I mistakingly called a script.  Sorry for that.  I
am not running that as a script, I am running my sh file as a script.
Now.  That being cleared up, When I run that loop, it seems that it
attempts to run the loop on applewmproto-1.4.2 regardless of the #.
Therefore, it errors out.  When I ran the loop OUTSIDE of the bash -e
shell, it obviously showed the error on that file, but continued on
and finished just fine.  So basically, my problem has been resolved.
I just thought it would be worth yall noting that the loop is not
ignoring the # files for w/e reason.
> http://linuxfromscratch.org/mailman/listinfo/blfs-support
> FAQ: http://www.linuxfromscratch.org/blfs/faq.html
> Unsubscribe: See the above information page



More information about the blfs-support mailing list