[blfs-support] Errors during Xorg Configuration

Cory Cline Cory at ClineCreations.net
Thu Oct 4 19:25:34 PDT 2012


On Thu, Oct 4, 2012 at 9:05 PM, Bruce Dubbs <bruce.dubbs at gmail.com> wrote:
> Cory Cline wrote:
>> It lists all the tarballs.  I am indeed in that directory.  Thanks for
>> the prompt reply :)
>>
>> On Thu, Oct 4, 2012 at 8:47 PM, Bruce Dubbs <bruce.dubbs at gmail.com> wrote:
>>> Cory Cline wrote:
>>>> Hello there!
>>>>
>>>> I am in the section titled "Xorg Protocol Headers"
>>>>
>>>> I am in the directory /sources/xc/proto/
>>>>
>>>> I issue the command:
>>>>
>>>> for package in $(grep -v '^#' ../proto-7.7.md5 | awk '{print $2}')
>>>> do
>>>>     packagedir=${package%.tar.bz2}
>>>>     tar -xf $package
>>>>     pushd $packagedir
>>>>     ./configure $XORG_CONFIG
>>>>     $AS_ROOT make install
>>>>     popd
>>>>     rm -r $packagedir
>>>> done
>>>>
>>>> And it yields me the result: "tar: >: Cannot open.  No such file or directory"
>>>>
>>>> Any idea of the cause of this?
>>>
>>> I think you have some kind of typo.  What do you get from:
>>>
>>> $ grep -v '^#' ../proto-7.7.md5 | awk '{print $2}'
>>>
>>> You need to be in the directory with the tar.bz2 files to start.
>
> Please don't top post.
>
> Then test out the compound command with:
>
> for package in $(grep -v '^#' ../proto-7.7.md5 | awk '{print $2}')
> do
>      packagedir=${package%.tar.bz2}
>      echo $packagedir $package
>      #tar -xf $package
>      #pushd $packagedir
>      #./configure $XORG_CONFIG
>      #$AS_ROOT make install
>      #popd
>      #rm -r $packagedir
> done
>
> Work through it line by line to see where the problem is.
>
>    -- Bruce
> --

Sorry about the top post.  Never been on a mailing list before :P.
The error seems to be caused by the pushd $packagedir.  Any ideas on
what would be causing this?
> http://linuxfromscratch.org/mailman/listinfo/blfs-support
> FAQ: http://www.linuxfromscratch.org/blfs/faq.html
> Unsubscribe: See the above information page



More information about the blfs-support mailing list