I Hate gobject-introspection

Andrew Benton b3nton at gmail.com
Tue Jul 6 16:56:28 PDT 2010


Has anyone been able to compile gobject-introspection with python-2.7? I've 
just tried and gobject-introspection-0.9.0 fails to compile like so:

  GICOMP xlib-2.0.gir
  GICOMP xfixes-4.0.gir
  GICOMP xrandr-1.3.gir
Traceback (most recent call last):
  File "../tools/g-ir-scanner", line 36, in <module>
    from giscanner.scannermain import scanner_main
  File "/tmp/gobject-introspection-0.9.0/giscanner/scannermain.py", line 31, in <module>
    from giscanner.dumper import compile_introspection_binary
  File "/tmp/gobject-introspection-0.9.0/giscanner/dumper.py", line 26, in <module>
    from .glibtransformer import IntrospectionBinary
  File "/tmp/gobject-introspection-0.9.0/giscanner/glibtransformer.py", line 34, in <module>
    from .transformer import Names
  File "/tmp/gobject-introspection-0.9.0/giscanner/transformer.py", line 31, in <module>
    from .girparser import GIRParser
  File "/tmp/gobject-introspection-0.9.0/giscanner/girparser.py", line 32, in <module>
    from .girwriter import COMPATIBLE_GIR_VERSION
  File "/tmp/gobject-introspection-0.9.0/giscanner/girwriter.py", line 30, in <module>
    from .xmlwriter import XMLWriter
  File "/tmp/gobject-introspection-0.9.0/giscanner/xmlwriter.py", line 70, in <module>
    with LibtoolImporter:
AttributeError: __exit__
make[2]: *** [GLib-2.0.gir] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: Leaving directory `/tmp/gobject-introspection-0.9.0/gir'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/gobject-introspection-0.9.0'
make: *** [all] Error 2

If I install python-2.6.4 it compiles but I'd rather keep python up to 
date (and ditch gobject-introspection if I could). Google isn't comming 
up with any answers for me. Has anyone else got past this?

Andy



More information about the blfs-support mailing list