[BLFS-SUP] comments on BLFS development version and beyond

Aleksandar Kuktin akuktin at gmail.com
Sun Jan 24 03:05:21 PST 2010


>On Sun, 24 Jan 2010 02:48:00 +0200
>"Agathoklis D. Hatzimanikas" <a.hatzim at gmail.com> wrote:
>
> Hi Ken,
> 
> On Sat, Jan 23, at 02:42 Ken Koehler wrote:
>
> [ ... ]
>
> >      f) xpdf no longer works (requires Xprint, which in Xorg 7.5 is 
> > deprecated), so removed it
> 
> I don't use xpdf (requires mottif) and the development is stalled. But
> have you tried to build Xprint, even if is deprecated by upstream?
> Did it fail or what?

I also had problems building xpdf.

Now, this happened a few months ago so my memmory is a bit hazy, but as
far as I can remember, some parts of the package built well, but xpdf
itself failed. Investigation showed that it belived Mottif was missing.
I was puzzled by this as I have installed Lesstif. Turned out that
somehow Xm/Print.h got included and it (tried to) include
X11/extensions/Print.h which was missing.

So I just took a copy from the previous build. :)

It works fine now, aldough I have not tried printing from xpdf.

-AKuktin



More information about the blfs-support mailing list