[BLFS-SUP] comments on BLFS development version and beyond

Agathoklis D. Hatzimanikas a.hatzim at gmail.com
Sat Jan 23 16:48:00 PST 2010


Hi Ken,

On Sat, Jan 23, at 02:42 Ken Koehler wrote:
 
>      d) had to remove newport, vmware, xgi and xgixp drivers so Xorg 
> -configure wouldn't lock system (responded to Alt-SysRq but nothing 
> else) Note I am using radeon x850xt

There is a warning to the book, to built only the supported drivers for
your chipset.

>      f) xpdf no longer works (requires Xprint, which in Xorg 7.5 is 
> deprecated), so removed it

I don't use xpdf (requires mottif) and the development is stalled. But
have you tried to build Xprint, even if is deprecated by upstream?
Did it fail or what?
 
> 4) fontconfig must be installed before cairo, otherwise pango will not 
> find any cairo backends usable, and GK+-2 won't build

Yes, already fontconfig is a requirement to build cairo.

> 5) gsview text searching in pdf files doesn't work with either ps2ascii 
> or pstotext... after fighting for a day trying to find a pdf reader that 
> will work and allow text searching, I finally caved and downloaded acroread

Epdview is capable to do searches to pdf documents.
It requires the poppler libray and GTK+2. The same applies for apvlv, a rather
new pdf-viewer, with vi(m) key bindings.

Also gv, is started to be under maintenance (after years), but under the GNU
umbrella this time, but it still requires the outdated Athena toolkit (I don't
really understand what kind of development is that).

http://www.gnu.org/software/gv/

> 6) alsa-plugins 1.0.21 requires updated ffmpeg, used svn 20070606
>
> 7) mplayer 1.0rc4 does not recognize --enable-shared-pp
 
There are no formal releases for both of ffmpeg and mplayer, so there is no
other way for BLFS, than to checkout (periodically) the repos and store the
snapshots in the LFS infrastructure. That's the only way to stabilize the
instructions and the configure switches that they are changing frequently.

> 8) wxGTK 2.4.2, needed for audacity 1.2.6, requires 2 patches to work 
> with gcc4:
>      wget --no-check-certificate 
> https://bugzilla.redhat.com/attachment.cgi?id=113243
>      mv attachment.cgi?id=113243 wxGTK-2.4.2-gcc4.patch
>      wget --no-check-certificate 
> https://bugzilla.redhat.com/attachment.cgi?id=113274
>      mv attachment.cgi?id=113274 wxGTK-2.4.2-gcc4_v2.patch

A little bit of topic. 
I am not familiar with wget anymore (haven't use it for years), but with
curl you have the option to provide a certificate and it's possible to fetch
the sources from https.
Again, probably wget is capable to do that kind of thing.


> 9) gimp 2.6.8 requires babl svn, gegl svn (which requires ruby 
> 1.8.7-p72), also Python 2.6.2 (for scripting) and gettext 0.17

Both of these scripting languages have released new versions, in that
same branches (1.8.7 and 2.6 respectively). Because of the nature of
them, is recommended to upgrade to their new point releases (don't try
to change branches, unless you rebuilt all the stuff around them).
Python for sure and Ruby I think, they are providing slots to make it
easy to use different versions of the languages, so you can experiment
with new features. Usually applications are getting time to be ported to
the new major releases. For example mercurial (a very popular vcs) doesn't
built with Python-3*.

> 10) If you want gimp built-in help browser, you need: pycairo 1.4.0, 
> pygobject 2.12.3, pygtk 2.10.6, libgtkhtml 2.11.1, gperf 3.0.4, icu 
> 4.2.1, enchant 1.5.0, sqlite 3.6.16, libsoup 2.28.1, gstreamer 0.10.25, 
> liboil 0.3.16, gstreamer base plugins 0.10.25, webkit gtk 1.1.15

Wow! All those dependencies just to access the help system. I am happy
that I don't have the slightest interest for photos. But, this is getting
insane.

>      note: webkit puts a bunch of intl directories in /; I moved them to 
> /usr/local/share/webkit-1.0/

I've tried in the past to build webkit and I don't think that happened that
same thing to my build. I want believe that there has to be some human
error from your part, otherwise this is clearly a bug to webkit building
system. Have you tried to (re)confirm and report it?

> 11) I installed xscreensaver 5.10, and ended up (as before) setting it 
> to just blank the screen because in a matter of minutes to hours it 
> locked my system up tight (wouldn't even respond to Alt-SysRq)

I am not sure there is still a development or an interest to continue
development for those archaic tools. In my opinion those specialized 
tools is out of scope of Xorg, or should be, and Xorg should concentrate
to provide only a stable X server. Everything else is better to provided
by third sources.

> 12) needed to install STIX fonts for seamonkey 2.0.1 to properly render 
> HTML entities 
> (http://www.mozilla.org/projects/mathml/fonts/stix/STIXBeta.zip) 

In firefox-3.6 (just installed) are displayed just fine. Funny, but why
this torture?

And a reference for the future. Your email is better suited to the
BLFS development list, rather to support.

Regards and thanks for the info.



More information about the blfs-support mailing list