NFS issues

Ken Moffat zarniwhoop73 at googlemail.com
Sat Jan 9 15:02:02 PST 2010


Two unrelated issues with my current build (svn-20091221
on x86_64).

1.  I tried nfs-utils-1.2.1, but mount objected to one or more of
my options on each of my (nfsv3) mounts, e.g. something in

myserver:/path/to/sources /sources nfs rw,hard,intr,_netdev,tcp 0 0
and
myserver:/path/to/notes /home/ken/notes nfs rw,hard,intr,noauto,tcp,user 0 0

 I'm at a loss to identify what changed (strace just showed 'invalid option'
for the call, man 5 nfs doesn't show anything obvious).

 I've reverted to 1.2.0 and all my mounts are working again,
so without any clues I'm treating this as a low priority (google
mainly comes up with kernel changes).

 The log message was
NFS: bad mount option value specified:vers=4
 which made me wonder if I'd inadvertently built for nfsv4,
but even on 1.2.0 I've got mount.nfs4 as a link to mount.nfs
[ --disable-nfsv4 : also tried --enable-nfsv4=no with
1.2.1]

2. On clfs, I've had issues with the netfs bootscript at
shutdown (dropped to "enter root password for
maintenance" prompt, apparently triggered because
the invocations of fuser were failing.  I recall someone
else had this, but I don't think he ever said what system
he was using. [ clfs has copies of what were the BLFS
scripts, but I happen to use the BLFS scripts ].

 In my current build I've got the 'fuser' lines commented
out, because everything has worked well enough without
them (and failures during shutdown are not nice - I can
reboot with Magic SysRQ, but not halt), but I thought
I might as well look a little closer.

First, fuser is in /usr/bin, at least with coreutils-8.2, so
the script isn't up to date in trying to use /bin/fuser.

Second, fuser might be broken: I can't get it to accept
the signal, neither -SIGTERM nor -TERM nor even -HUP,
it just tells me it doesn't like what I passed to it, and
that I should use fuser -l.  The signals listed by doing
that include HUP and TERM which is why I suspect
breakage.

I might raise a ticket suggesting we drop these
invocations of fuser (the simplest workaround)
but the only net fs I use is nfs - perhaps they
are beneficial to one of the other filing systems ?

ĸen
-- 
After tragedy, and farce, "OMG poneys!"



More information about the blfs-support mailing list