Building LFS/BLFS through ssh session question

stosss stosss at
Tue Feb 16 21:22:07 PST 2010

On Wed, Feb 17, 2010 at 12:08 AM, Bruce Dubbs <bruce.dubbs at> wrote:
> stosss wrote:
>> I got around the problem. I have sent info to kde and the distro that
>> is having the problem to see if they can figure out where the problem
>> is. It is happening on kde4.3.4 on my PCLinuxOS but it does not happen
>> in kde3.5.10 on any distro I have tried. The problem is vim will not
>> work across ssh in xterm on kde4 on PCLinuxOS but will in a real
>> terminal.
>> Initially I was wondering if I was messing up my build on (B)LFS doing
>> it over ssh because vim was freaking out. I know what I have to do to
>> make it work so its all good.
> Please share a little more.  I admit that I still don't like kde4 so I
> don't use it.  As you say, there is no problem with kde3 that I've seen.
> I do know that most distros build X into vim and that can cause a
> problem if ssh isn't configured to handle that.
> What was the workaround that solved your problem?

Okay, in the xterm it will not work at all (this is on a PCLinuxOS
kde4.3.4) but switching from F7 to F1-F6 into the terminal and trying
it from there worked like it is supposed to work. Still waiting to see
if anyone from PCLOS and kde know why it is not working in kde4 xterm.

If some one does not know the command string ssh -t user at rhost 'vi
directory/file' works like a charm.

More information about the blfs-support mailing list