libdrm and xorg-server

Rick Shelton rick.shelton at gmail.com
Tue Apr 6 10:04:51 PDT 2010


> It appears that you said you are building LFS 6.6 and BLFS 6.3 on top
> of it. If that is correct that is your problem. If you are Building
> LFS 6.6 you should be building BLFS using the svn version. BLFS svn is
> compatible with LFS 6.6. BLFS 6.3 is not compatible and will give you
> trouble.

For the record, I am running LFS 6.6 with a mixed BLFS.
I want to use nVidia drivers with my system, but various troubles
narrowed my choices to Xorg 7.2 and an older driver release (190.xx).
So I installed Xorg 7.2 from BLFS 6.3.
Everything outside of the X chapter was installed according to
BLFS-svn-<last week>. Besides Xorg 7.2, the only BLFS-6.3 recommended
software required by X are the packages libdrm and Mesa.

The only package that was not compatible was libxml2-2.7.6 (BLFS-svn);
instead use libxml2-2.7.7.



More information about the blfs-support mailing list