hal and users mounting sticks

lux-integ lux-integ at btconnect.com
Fri May 15 19:31:23 PDT 2009


On Saturday 16 May 2009 01:01:36 am lux-integ wrote:

>
> i) If a single stick with two partitions (first fat second ext2)  is
> inserted. only the last   partition is mounted,    AND the files and
> directories are not displayed.
> ii) If a single stick  with a single partition  is inserted,  it is mounted
> but no files/directories are displayed.
> iii) If a  second stick   is inserted all partitions are mounted and
> displayed.  However the first partition appears to be mounted by root -see
> a) above.   And    write acess by normal user appears to be only available
> on fat partitions although ext2  was mounted r/w.

the  above   seems  to depend on how ivman is started.  If it is started with 
startkde   such as 

ln -s   /path/to/ivman  ~/.kde/Autostart/ivman

reliable behaviour is observed.      The   usb-sticks  shows up in the  pop-up 
plasmoid  thingy  and clicking thereon   opens up the volume in dolphin.  
However if the eject button is pressed,  the whole thing freezes.  The best 
way to unmount is using    pumount/media/usbdisk-x.    (pumount works for 
whoever is in the plugdev group)

I consider what I  have   now is a decent  stopgap  until kde4.3.0  hardenes 
(where hopefully the user mounting/unmounting of   hot-plugabble    devices  
such as usb-sticks  will work more reliably).  I hope   those who had similar 
problems have been able to gain  something useful    from this thread.

 lux-integ





More information about the blfs-support mailing list