linux-atm241, gcc4.2, speedtouch, LFS

b-vol lux-integ at btconnect.com
Wed Jun 25 08:52:49 PDT 2008


On Wednesday 25 June 2008 02:20:37 pm Ken Moffat wrote:
> On Wed, Jun 25, 2008 at 08:00:36AM +0100, b-vol wrote:
> > Greetings,
> >
> > I have been using speedtouch 330's on an LFS Linux box  for  a few years
> > now.   I just tried  to upgrade  to a new box with  LFS-SVN-20071223 
> > glibC-2.7, GCC4.2.2  kernel 2.6.25.8 (this is my upgrade)  using the
> > recipe given at :-
> >
> >  http://www.linux-usb.org/SpeedTouch/LFS/index.html
> >
> > However linux-atm-2.4.1  fails to compile with the patch provided.   The
> > errors reported are as   follows:-
> >
> > #errors of the type are  reported:-
> > <stdin>:93:1: error: pasting "}" and "best_effort" does not give a valid
> > preprocessing token
> > <stdin>:138:3: error: invalid preprocessing directive #Note
> >
> > #later on more serious errors:-
> > make[3]: *** [arp.o] Error 1
>
> [snipped, but thanks for including this!]
>
>  Looks as if gcc-4.2 dislikes something here.
>
> >  Does anyone know of a patch that will enable it to compile?  Or any
> > dependencies?  Or know of an updated  version of the   linux-atm package?
>
> http://sourceforge.net/projects/linux-atm/ shows 2.5.0 came out in
> December.  That version seems to be used by Suse and fedora.  I've
> forgotten where to look to find the details of fedora patches, so I
> used rpm2cpio and cpio to extract the srpm.  Fedora apply the two
> patches I've attached.  No idea if they are necessary!
>
> HTH
>
> ĸen

thanks for your help linux-atm-2.5.0 and patches  works with gcc4.2

l-i

-- 

###################################
Money only has value when people trust it. 
If the trust goes -then poooof!
Buy gold people

--Anonymous 2008



More information about the blfs-support mailing list