Samba shutdown issues.

Craig Magee psybertao at gmail.com
Fri Sep 14 19:33:52 PDT 2007


Hi all,
I'm using LFS 6.1 and just compiled cups-1.2.12 and Samba-3.0.23d.  smbd and
nmbd both start fine, but there is a problem with stopping them.  While
running, when I do '/etc/rc.d/init.d/samba status' it reports a pid for
nmbd, and TWO for smbd.  When stopping them the script reports success with
stopping smbd, but a 'fail' with nmbd.  When checking the status with the
samba script(after the services have been stopped) it reports that smbd and
nmbd aren't running, but nmbd.pid and smbd.pid are both still in the
/var/run folder.
I've tried deleting the pid files after stopping the services, restarting
them, then stopping, only to get the same problem.
The smb.conf script is nothing more than the standard file/print server
entry in BLFS.  I haven't added any samba users apart from 'nobody' using
smbpasswd.  It's not convenient for me to try and find a box to network to
my computer for testing yet.  I will if anyone thinks it will help, but on
the previous times I've set up samba it worked without issues and don't
think it's releated to my problem.
The samba log doesn't report any major problems, I tried with 'log level =
3', but can't glean anything helpfull from it.

Any advice or ideas would be greatly appreciated.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/blfs-support/attachments/20070915/5eba3c18/attachment.html>


More information about the blfs-support mailing list