fluxbox woes

Peter B. Steiger pbs_lists_001 at bluebottle.com
Mon Sep 10 07:45:31 PDT 2007


I built xorg 7.2 this weekend on the LFS that I built last weekend, and
everything works as it should.  But when I change .xinitrc to launch
fluxbox as my window manager, the X desktop flashes into view for a
fraction of a second and then disappears as X exits back to the console.

I'm 92.41% sure it's not X, because twm and xterm work fine; it's only
fluxbox that fails.  I rebuilt with debugging included so the exit
messages are a little more comprehensive, but all that did was list all
the compile options... there are no errors. Several warnings where it
could not find specific font options in the layout, but my old fb on
xorg 7.1 does that too.

I tried both the stable version (which I currently run on the old
system) and the development version with identical results.  I tried
wiping out my home directory and creating a default new .fluxbox
directory.  It's not a rights issue because the same thing occurs as
root or my normal login.  I even tried copying the working binary and
config files from my old partition to the new one, with the same
results.

Kernel is 2.6.22.6, gcc is 4.12, X was built with Mesa drivers for my
Radeon 7000 (and in fact glxgears works fine when I launch xorg with
twm).

I guess the next step is to edit the fluxbox source and put in
breakpoint messages to tell me exactly how far it gets before
crashing... unless anyone else has a better suggestion?

-- 
Peter B. Steiger
Cheyenne, WY

----------------------------------------------------------------------
Get a free email address with REAL anti-spam protection.
http://www.bluebottle.com/tag/1




More information about the blfs-support mailing list