compiling samba with pam, but it's not finding the libraries

Dan Nicholson dbn.lists at gmail.com
Sun Sep 2 08:28:12 PDT 2007


On 9/2/07, Alan <arwomack01 at webbyhome.com> wrote:
> see interspersed
>
> On 9/2/07, Dan Nicholson <dbn.lists at gmail.com> wrote:
> > On 9/2/07, Alan <arwomack01 at webbyhome.com> wrote:
> > > checking whether to build mount.cifs and umount.cifs... yes
> > > checking whether to try PAM support... yes
> > > checking security/pam_appl.h usability... yes
> > > checking security/pam_appl.h presence... yes
> > > checking for security/pam_appl.h... yes
> > > checking for pam_get_data in -lpam... no
> > > configure: error: --with-pam=yes but libpam not found
> >
> > The second to last line either means it couldn't find libpam or that
> > it didn't have the function pam_get_data. You'll have to look near the
> > end of config.log.
>
> #define WITH_SMBMOUNT 1
> #define WITH_CIFSMOUNT 1
> #define HAVE_SECURITY_PAM_APPL_H 1

You'll have to go back a bunch of lines from there. Search for -lpam.
The test compile should follow that and say what happened when it
tried to link. Here's what it says (successfully) for me:

configure:42435: checking for pam_get_data in -lpam
configure:42465: gcc -o conftest -g -O2 -march=pentium4 -pipe
-D_SAMBA_BUILD_  -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
-D_GNU_SOURCE -DLDAP_DEPRECATED -Wl,--as-needed  conftest.c -lpam
-lcap -lresolv -lresolv -lnsl -ldl  >&5
configure:42471: $? = 0

--
Dan



More information about the blfs-support mailing list