firefox, mozilla, thunderbird segfault

Christopher Beppler lfs at funzi.de
Sun Jul 24 15:40:19 PDT 2005


Jens Olav Nygaard wrote:
> Ken Moffat wrote:
> 
>>> /usr/lib/firefox-1.0.6/run-mozilla.sh: line 159:  5403 Segmentation
>>> fault      "$prog" ${1+"$@"}
> 
> ...
> 
>>  I see your machine is called opteron - is this a 64-bit, multilib, or
>> 32-bit system ?
> 
> I've just had the exact same symptoms, don't know if the problem was
> the same as yours. (This message is written with the just compiled
> thunderbird 1.0.6 on my x86_64 build.)

gratz ;-)
Which LFS-Version do you use?

> 
> First, take note of the advice regarding the X-fonts, I think that was
> (one of) my problem(s). I had forgotten it, got the crashes, fixed it,
> and things work. Unfortunately I also did some other stuff which

What have I to do? I checked the font-paths, I run mkfontscale &&
mkfontdir in the font-dirs an fc-cache at all... the
/etc/fonts.local/conf is correct, too... Did I forgot something?

> may have affected things, namely doing a rebuild of firefox+thunderbird
> on the new system. I have tried numerous times to build it in the
> chroot-environment on the host, with little success. The first version
> of firefox which seg.fault'ed was "forced through" a compile in this
> chroot environment, it was probably rather buggy.

I don't compile in a chroot-environment. I compile via ssh.

> I guess my advice would be to try 1) build on the new system not in the
> chroot env. of the host, and 2) check the font-stuff.

1) done... (via ssh)
2) what else may I have to do?

> (Note, for me at least, it was not sufficient to follow the book, for
> some strange reason the fonts ended up in /usr/lib64/fonts etc., not
> under any usual X-location at all...)

Do you use a multi-lib-OS? Or a clean 64bit one?

> 
> J.O.

Christopher



More information about the blfs-support mailing list