Short questions on DHCP

D.Moriarty declan.moriarty at
Fri Oct 22 01:43:35 PDT 2004

Ken Moffat wrote:

> On Thu, 21 Oct 2004, D.Moriarty wrote:
>>I've been there and tried most of that. It hangs because I still have
>>LFS-3.3 and the boot scripts are a little different. I can't be exact
> Ok, from my firewall which is running something around lfs-3.3 (doesn't
> seem to have any /etc/lfs-* so I can't be sure of the exact version) and

Glibc-2.2.5? That's probably a good timestamp.
> uses *eth1* for the connection to the world (eth0 for my lan).  Probably
> very badly done, but working.
If it's working, Ken, it's not very badly done :-)
[SNIP scripts]

My system barfs as follows: /etc/sysconfig/network fails to find 
$network_devices; I hacked that, and then it fails to find an IP and 
mentions  ifconfig.eth0. This is bull, as I tried IPs in there. So I 
figured to do it manually. I gather from your scripts you can do it 
manually by

modprobe eth1
dhclient eth1 -1

Mind you, this is the first outing for the network bootscript, so that 
takes me back to all the mistakes made building my very first lfs :-o.
> Note also that for this version of dhclient the leases are in
> /var/state/dhcp/dhclient.leases and you will need to touch that (or
> wherever your version is looking) before you can get a lease.

Yeah, the dhclient.leases have their own manpage.

         With Best Regards,

         Declan Moriarty

More information about the blfs-support mailing list