Commoncpp problems on LFS 5.0 system

Matthew Burgess matthew at linuxfromscratch.org
Sun Apr 18 04:00:40 PDT 2004


On Sun, 18 Apr 2004 06:18:59 -0400
Serge Delorme <s_del at megacom.net> wrote:

> Le dimanche 18 avr. 2004 à 03:20:23 +0200, Vidar Hoel a écrit:
> > I unpack commoncpp2-1.1.0.tar.gz, and run:
> > ./configure --prefix=/usr --with-linuxthreads
> > 
> > (I have also tried with "--with-pthread")
> 
> <snip> 
>  
> > Has anyone compiled commoncpp without problems? Are I the only one
> > with the same error on all my three LFS-boxes?
>  
> I tried version 1.1.3 with linuxthreads/pthread and I get the same
> error... 

And I tried 1.1.4 and got the same.  To fix most of the errors change
line src/thread.cpp:1043 to read "void	Thread::setCancel(Cancel mode)".
 It looks as if they renamed the enum in thread.h, but didn't update
thread.cpp to reflect this.

There's still a problem with src/thread.cpp:98 which can be worked
around by removing either the 'extern "C"' from the beginning of that
line, or the keyword "static". NOTE: I don't have any confidence that
which one of these (if either) is the correct solution though.
Regardless, the build fails later on with a 'cannot find -llthread'.
Methinks the configure script (or config.log) needs further
investigation to see where the real problem is.

Hope this helps a little.

Matt.



More information about the blfs-support mailing list