(no subject)

Declan Moriarty declan.moriartyt at ntlworld.ie
Thu Apr 15 01:23:57 PDT 2004


raman_montylee enlightened us
> Hi there,
> I have completed LFS 5.0.
> It runs fine from the harddisk.
> I have created a bootable CD that runs fine from my computer.
> But when i run the mount command it shows my harddisk partition mounted on which i created my LFS system, so i think the CD still depends on the harddisk.
> If i run the CD on a different computer it gives the following error: 
> 
> ds: no socket drivers loaded!
> hda6: bad access: block=2, count=2
> end_request: I/O error, dev 03:06 (hda), sector 2
> EXT2-fs: unable to read superblock
> hda6: bad access: block=64, count=2
> end_request: I/O error, dev 03:06 (hda), sector 64
> isofs_read_super: bread failed, dev=03:06, iso_blknum=16, block=32
> Kernel panic: VFS: Unable to mount root fs on 03:06
> 
> In my home i created LFS on /dev/hda6 so i think the CD is depending on the harddisk.
> I have created the boot cd from the faq given on the LFS website and the /etc/fstab file has no entry for the harddisk so i suppose i have done everything correct.
> 
> So, please help me to make a correct boot CD.
> Please reply soon as it is my final year project.

You are right. The kernel on the cd depends on your hard disk

Check your /etc/fstab, and your boot loader. In the loader (grub or
lilo) you have to specify which is the root filesystem. That should be
the cd.

I gather what you did was to copy the entire working LFS onto a CD? You
also have to make sure that your kernel has iso9660 _compiled__in_. Ext2
or ext3 can be a module.

--


	With best Regards,


	Declan Moriarty.



More information about the blfs-support mailing list