wrong kernel modules loaded

Christian H. Kuhn official at qno.de
Sun Apr 11 15:39:56 PDT 2004


Hi Duncan,

& dixit Duncan Webb:
> Christian H. Kuhn said:
>> I just compiled a new kernel version (2.4.25, before i had 2.4.22). It's
>> not the first time i did, but the first time with my LFS system. And now
>> i have a problem: If i do a depmod -a, modules are taken from
>> /lib/modules/2.4.22, not from /lib/modules/2.4.25. uname -r tells
>> 2.4.25, so i don't know where to look for the bug. Any hints?
>>
> Isn't this a problem with your System.map, you have the 2.4.22 System.map
> in the /boot directory.
 
[root at ns1 /boot]# ll -a
insgesamt 3,6M
drwxr-xr-x    3 root     root         4,0K 2004-04-11 22:34 .
drwxrwxr-x   19 root     root         4,0K 2004-03-26 15:03 ..
-rw-r--r--    1 root     root          26K 2004-03-24 17:07
config-lfskernel-2.4.22
-rw-r--r--    1 root     root          25K 2004-04-10 18:19
config-lfskernel-2.4.25
drwxr-xr-x    2 root     root         4,0K 2004-04-10 13:55 grub
-rw-r--r--    1 root     root         1,2M 2004-03-24 17:07
lfskernel-2.4.22
-rw-r--r--    1 root     root         1,2M 2004-04-10 19:11
lfskernel-2.4.25
-rw-r--r--    1 root     root         590K 2004-03-24 17:07
System.map-2.4.22
-rw-r--r--    1 root     root         626K 2004-04-12 00:01
System.map-2.4.25

To be sure that i did not mix things up, i untarred and recompiled the
kernel sources. It's a fresh kernel, and a fresh System.map.

> One way to solve this problem is
> depmod -ae -F /path/to/2.4.25/System.map 2.4.25

Solves only some of the problems. Instead of showing a list of all
2.4.22 modules, only:

[root at ns1 /boot]# depmod -ae -F /boot/System.map-2.4.25 2.4.25
depmod: *** Unresolved symbols in
/lib/modules/2.4.22/kernel/drivers/char/drm/gamma.o
depmod:         gamma_driver_irq_postinstall
depmod:         gamma_driver_irq_preinstall
depmod:         gamma_driver_irq_uninstall
depmod: *** Unresolved symbols in
/lib/modules/2.4.22/kernel/drivers/char/drm/sis.o
depmod:         sis_malloc_Ra3329ed5
depmod:         sis_free_Rced25333
depmod: *** Unresolved symbols in
/lib/modules/2.4.22/kernel/drivers/sound/snd-msnd-pinnacle.o
depmod:         mod_firmware_load_R39e3dd23
depmod: *** Unresolved symbols in
/lib/modules/2.4.22/kernel/drivers/sound/snd-tea575x-tuner.o
depmod:         video_register_device_R28efa16a
depmod:         video_unregister_device_Rf5332580
depmod: *** Unresolved symbols in
/lib/modules/2.4.22/kernel/drivers/sound/snd.o
depmod:         register_sound_special_R3333385b
depmod:         unregister_sound_special_R99c95fa5

There should not be those problems ...

Kind regards,
Chris




More information about the blfs-support mailing list