XFree86 4.3.0 i810 dri problem

Nic Hanno nicnews at ozemail.com.au
Tue Sep 16 09:17:02 PDT 2003


I have just installed an LFS system with XFree86 4.3.0.

I am having problems getting dri to function properly... The
/var/log/XF86...log states that dri is enabled and all dri related modules
loaded...

However, when I run glxgears I get a repitition of the glxgears window (and
gears) across the width of the screen and the gears themselves are all
squashed. Same as the display that this person has:

http://www.linux.ime.usp.br/~slave/gentoo.jpg

I have searched and found this problem from other users stating that
everything seemed ok on X 4.1.0 but not 4.2.0. Has this been fixed in 4.3.0?
Maybe not.

After a bit more searching I found this link:

http://rpmfind.net//linux/RPM/conectiva/9/cd1/conectiva/RPMS.001/XFree86-i810-dri-4.3.0-28971cl.i386.html

It seems like a patch for i810 / dri / 4.3.0... Has anyone tried this patch?
If so, how would I apply it? Is it possible to pull the appropriate
libraries from the .rpm. and how would one apply them?

I also noticed that the libGL library's version is slightly different from
the one in the readme.dri, README.dri files in the XF86 4.3.0 doc folder
(ftp, not installed doc folder). Should I attempt to match the library
version(s) before I do anything else? My LFS and BLFS install was 'by the
book' - i.e. all versions used for the complete install were the same as the
book.

Any help ofcourse greatly appreciated...

Nic.





More information about the blfs-support mailing list