Upgrading libraries

Alexander E. Patrakov semzx at newmail.ru
Sun Mar 16 06:44:52 PST 2003


Sorry for doing that too late.

Today I recompiled OpenSSL (updated from 0.96h to 0.97). Now both versions are 
in /usr/lib.

Then I downloaded and compiled SAMBA 2.2.8. This resulted in the following 
linker warnings:

/usr/bin/ld: warning: libssl.so.0.9.6, needed by 
/usr/lib/gcc-lib/i686-pc-linux-gnu/3.2.1/../../../libcups.so, may conflict 
with libssl.so.0.9.7
/usr/bin/ld: warning: libcrypto.so.0.9.6, needed by 
/usr/lib/gcc-lib/i686-pc-linux-gnu/3.2.1/../../../libcups.so, may conflict 
with libcrypto.so.0.9.7

1) Is it safe to ignore them now since I plan to recompile everything that 
depends on OpenSSL? The resulting smbd seems to work.
2) How do I find all binaries that depend on OpenSSL 0.96h?

-- 
Alexander E. Patrakov

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list