X11 libs

torsten torsten at howard.cc
Fri Mar 14 16:24:01 PST 2003


On Fri the 14 Mar 2003 at 18 hours EST
TC wrote...
>I am trying to run an Unreal Tournament server on my lFS 4.0 machine but it
>requires some X libraries. Specifically it wants libX11.so.6 and
>libXext.so.6. I dont have xfree86 installed on the machine in question nor
>do I really want to do so but I need those libraries to run the server. What
>I did was I copied libX11.so.6.2 and libXext.so.6.4 from my knoppix 3.1 cd
>into my /usr/local/lib folder and then made symlinks to get the appropriate
>names. The problem there is that I am using glibc 2.2.5 and these libraries
>were linked against glibc 2.3 on the knoppix cd, thus making this solution
>unusable. My question is, is there any way to only compile these libs if I
>downloaded X11 source and avoid doing a full compilation? Barring that,
>could anyone plz mail me those two libs if they have them compiled against
>glibc 2.2.5? Thanks!
>
>

Run ldd on the X libraries, find out exactly which ones they want, then
symlink your current X libraries with names matching the needed libraries.

Torsten
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list