disapearing libqt-mt.so.3.1.1?

John Gay jgay at celestica.com
Thu Mar 6 13:49:50 PST 2003


>
>I think it's because your prefix is messed up; you can try this though:
>
This prefix set-up worked fine for me with qt-3.0.6 though. I have deviated
from the instructions a bit, using /etc/profile to set-up QTDIR, MANPATH
and LD_LIBRARY_PATH in accordance with the QT INSTALL instructions to point
to /usr/qt rather than the BLFS instructions. I unpack qt into
/usr/qt-3.1.1 and link this to /usr/qt
>
>export QTDIR=$PWD
>./configure -prefix /usr -plugindir /usr/lib/qt/plugins -datadir
>/usr/share/qt -release -shared -qt-gif -system-zlib -no-g++-exceptions
>-thread -sm -plugin-imgfmt-png -plugin-imgfmt-jpeg -plugin-imgfmt-mng
>-system-libpng -system-libjpeg -system-libmng -xft -xrender -no-xinerama
>-docdir /usr/share/doc -no-nis -disable-opengl &&
>export $PATH=$PWD/bin:$PATH &&
>make &&
>make install
>
I am using:
./configure -prefix=/ust/qt -qt-gif -system-libpng -system-libmng
-system-zlib
-system-libjpeg -no-g++-exceptions -threads

make
works fine, and creates lib/libqt-mt.so.3.1.1 along with the rest.

make install
fails ld cannot find -lqt-mt and lib/libqt-mt.so.3.1.1 is missing, though
the rest are there still linked to the missing lib?

This setup worked fine for qt-3.0.6? I was hoping to use this so I could
easily upgrade qt and KDE by compiling them under /usr/qt-3.2 and
/usr/kde-3.2 and just changing the links for /usr/qt and /usr/kde

>Now put in /etc/profile "QTDIR=/usr"
>
>Btw qt-3.1.2 is out...

Yes, but I'm on a dial-up with pay-per-minute charging. I had a friend
fetch these sources for me and put them onto CD's for me.
>
>
>--
>Groeten/Greetings
>Jeroen Coumans
>

Cheers,

      John Gay


-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list