Trouble compiling wvdial

James Doherty linuxman at slingshot.co.nz
Wed Mar 5 01:25:42 PST 2003


Hi guys,

I had quite a bit of trouble compiling wvstreams a couple of days ago. (Just 
to give you an idea of my setup - gcc-3.2.2 w/ glibc-2.31). I found a gcc-3.2 
patch through google (it was a couple of kb) but it didn't make any 
difference.

I then found this patch:
http://linuxfromscratch.org/~billyoc/wvstreams-gcc-3.2.1.patch

I can compile wvstreams successfully with that, but then I am unable to 
compile wvdial - here is the error:

/usr/include/wvstreams/wvconf.h:66: warning: implicit typename is deprecated,
   please see the documentation for details
g++   -o wvdial wvdial.o wvdial.a  -L../wvstreams -lwvutils -lwvstreams
/usr/lib/gcc-lib/i686-pc-linux-gnu/3.2.2/../../../libwvutils.so: undefined 
reference to `crypt'
collect2: ld returned 1 exit status
make[1]: *** [wvdial] Error 1
make: *** [src] Error 2

I would really appreciate some help on this one - I'm desperately waiting to 
be able to use my new GNOME 2.2 desktop on the internet :)

Thanks
-- 
James Doherty
ICQ: 53031226 | Jabber: segfaultnz at jabber.org
Aug. 25, 1991 - The day that Linux was born

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list