Compiling rpm

Adam Ottley aottley at
Mon Oct 15 17:57:01 PDT 2001

On October 15, 2001 06:58 am, you wrote:
> It has been a while since I've tried compiling rpm under a LFS system, but
> I could never get it to work.  Has anyone had any success at it?  I don't
> use rpms much but would be nice to have a working copy for those annoying
> people who only release rpms.

It worked for me using the rpm-glibc22 LFS-hint.  There are a couple of 
caveats, though:

1.  Make sure you use db-3.1.17 like the hint says; version 3.3.11 will not 
work.  I had to install db-3.1.17 to build RPM, then I installed db-3.3.11 
for everything else that uses db.  It doesn't cause problems because you end 
up with separate and libraries for the programs that 
depend on them.

2.  Compiling the static db-1.85 library fails unless you make a change in 
db.1.85/PORT/linux/Makefile.  In that file, find these lines:

  ar cq $@ \
    `lorder ${OBJ1} ${OBJ2} ${OBJ3} ${OBJ4} ${OBJ5} ${MISC} | tsort`

and replace them with:

  ar cru $@ ${OBJ1} ${OBJ2} ${OBJ3} ${OBJ4} ${OBJ5} ${MISC}

"lorder" seems to be a BSD program for ordering object files, but I have no 
idea where it comes from.

Unsubscribe: send email to listar at
and put 'unsubscribe blfs-support' in the subject header of the message

More information about the blfs-support mailing list