Anyone Familiar With writing Linuxrcs?

Chris Lingard chris at stockwith.fsnet.co.uk
Wed Dec 12 15:53:59 PST 2001


Alan Lord wrote:

> Hi All,
> 
> I'm trying to get a bootable CD using my clean and shiny LFS 3.1 system,
> before I fill it up with all the stuff that slows it down ;-)
> 
> I've used a template from http://www.stockwith.uklinux.net/ by Chris
> Lingard which is very simple to understand and seemed to fit my bill
> almost exactly.

Thank you.  I corrected some mistakes a few weeks ago.  Are you using the 
latest web page as a README?

> 
> I've modifed some things (I use devfs and isolinux) but it's pretty much
> the same.
> 
> Everything's fine until  I run linuxrc... When I get to the critical line:
> 
> exec chroot . /sbin/init <dev/console >dev/console 2>&1
> 

chroot has got to exist on both systems;  the RAMDISK that creates the 
system, and the system that you are changing to.

I forgot to tell everyone that PATH must be set up so that programs are 
found.

Did the original system work?  

> All I get is init telling me:
> 
> Usage: init 0123456SsQqAaBbCcUu
> 

I have no idea.  I will think about this

> I've tried all sorts of things to figure out why it doesn't do what it
> should (I've currently got linuxrc as a symbolic link to /bin/bash and I
> run it manually from the command line.) Same problem.
> 

This should work.  If you have the lilo.conf from the package;  then after 
Linux has booted it will give control to script linuxrc.

> Anyone got any bright ideas???
> 

Chris

> TIA
> 
> Alan

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list