Anyone Familiar With writing Linuxrcs?

Alan Lord lord_alan at hotmail.com
Wed Dec 12 14:19:24 PST 2001


Hi All,

I'm trying to get a bootable CD using my clean and shiny LFS 3.1 system,
before I fill it up with all the stuff that slows it down ;-)

I've used a template from http://www.stockwith.uklinux.net/ by Chris Lingard
which is very simple to understand and seemed to fit my bill almost exactly.

I've modifed some things (I use devfs and isolinux) but it's pretty much the
same.

Everything's fine until  I run linuxrc... When I get to the critical line:

exec chroot . /sbin/init <dev/console >dev/console 2>&1

All I get is init telling me:

Usage: init 0123456SsQqAaBbCcUu

I've tried all sorts of things to figure out why it doesn't do what it
should (I've currently got linuxrc as a symbolic link to /bin/bash and I run
it manually from the command line.) Same problem.

Anyone got any bright ideas???

TIA

Alan


-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list