[blfs-dev] Samba-4.7.3 build fails if docbook-xsl-1.79.1 is installed

Armin K. krejzi.lfs at email.com
Sun Dec 31 12:19:13 PST 2017


On Sat, 2017-12-30 at 09:57 -0500, Ryan Marsaw wrote:
> On 12/28/17 10:47 AM, "Armin K." <krejzi.lfs at email.com> wrote:
> > On 28.12.2017. 15:40, Ryan Marsaw wrote:
> > 
> > > The error is with the docbook-xsl-1.79.1 package, which is
> > described in 
> > > better detail here:
> > > https://bugzilla.redhat.com/show_bug.cgi?id=1491307
> > > 
> > > There is a patch available here:
> > > https://anonscm.debian.org/cgit/collab-maint/docbook-xsl.git/plai
> > n/debian/patches/765567_non-recursive_string_subst.patch
> > > 
> > > I can confirm that applying this patch to docbook-xsl-1.79.1
> > prior to 
> > > building
> > > Samba results in a clean build of Samba.
> > > 
> > > Regards,
> > > 
> > > Ryan
> > > 
> > > 
> > 
> > As a side note, docbook-xsl upstream has changed and there's now
> > 1.79.2 
> > version available at
> > 
> > https://github.com/docbook/xslt10-stylesheets/releases
> > 
> > It fixes the mentioned bug.
> 
> Thanks for the information about GitHub.  It never occurred to me to
> check
> there, as I usually do for packages that tend to stagnate!
> 
> However, even with the newest docbook-xsl-1.79.2, I'm still getting
> the same
> exact error when building Samba.  It appears that the upstream fixes
> didn't cut
> it, at least not for me.  I re-diffed the original patch to take into
> account the
> changes from docbook-xsl-1.79.1 and have included it here.
> 
> Regards,
> 
> Ryan

Right ... Now that you mention it, I see that I also have the patch
applied.


More information about the blfs-dev mailing list