[blfs-dev] WebKitGTK+ with enchant-2

Armin K. krejzi.lfs at email.com
Wed Dec 20 08:04:11 PST 2017


On 19.12.2017. 23:50, Bruce Dubbs wrote:
> Kian Moretz wrote:
>> In the latest (systemd) BLFS book from 2017-12-17, WebKitGTK+ doesn't
>> recognize enchant as being installed when using the enchant-2 version
>> included in the current book. By installing enchant-1.6.0 from 
>> BLFS-8.1, I
>> was able to get cmake to recognize enchant when building WebKitGTK+. Not
>> sure if this is an issue with WebKitGTK+ or something BLFS should
>> recognize and change.
>>
>> It might be necessary to include two different versions of enchant in 
>> BLFS
>> in order to allow packages to build properly. I'm not entirely sure what
>> the best solution would be here, but it's something that should probably
>> be looked into.
> 
> Are you sure?  I only have enchant-2.1.3 installed and
> 
> $ ldd /usr/lib/libwebkit2gtk-4.0.so.37.24.6|grep enchant
>      libenchant.so.2 => /usr/lib/libenchant.so.2
> 
>    -- Bruce
> 

I'm pretty sure that's a leftover from 2.1.2 (or earlier), since 2.1.3 
was made to be coinstallable with 1.6.x and earlier 2.x.y releases by 
appending -2 to everything it installed.


More information about the blfs-dev mailing list