[blfs-dev] WebKitGTK+ with enchant-2

Bruce Dubbs bruce.dubbs at gmail.com
Tue Dec 19 17:48:26 PST 2017


Kian Moretz wrote:
> ---- On Tue, 19 Dec 2017 17:50:46 -0500 *Bruce Dubbs
> <bruce.dubbs at gmail.com>* wrote ----
>
>     Kian Moretz wrote:
>      >> In the latest (systemd) BLFS book from 2017-12-17, WebKitGTK+ doesn't
>      >> recognize enchant as being installed when using the enchant-2 version
>      >> included in the current book. By installing enchant-1.6.0 from
>     BLFS-8.1, I
>      >> was able to get cmake to recognize enchant when building
>     WebKitGTK+. Not
>      >> sure if this is an issue with WebKitGTK+ or something BLFS should
>      >> recognize and change.
>      >>
>      >> It might be necessary to include two different versions of enchant
>     in BLFS
>      >> in order to allow packages to build properly. I'm not entirely
>     sure what
>      >> the best solution would be here, but it's something that should
>     probably
>      >> be looked into.
>
>      > Are you sure? I only have enchant-2.1.3 installed and
>      >
>      > $ ldd /usr/lib/libwebkit2gtk-4.0.so.37.24.6|grep enchant
>      > libenchant.so.2 => /usr/lib/libenchant.so.2
>
>
> It seems that on my system, enchant-2.1.3's libenchant is in
> /usr/lib/libenchant-2.so.2. This might be responsible for the issues I was
> having. Is      this standard behavior for enchant-2.1.3, or did I install
> it incorrectly?

I do not know.  I just used the instructions in BLFS.

   -- Bruce




More information about the blfs-dev mailing list