[blfs-dev] Valgrind 3.10.1 Linux 4.0 patch

Bruce Dubbs bruce.dubbs at gmail.com
Thu May 21 16:10:02 PDT 2015


Douglas R. Reno wrote:
> Hi all,
>
> I need to have someone else's opinion about how to add the patch into
> the instructions. Since it needs configure.ac, autoreconf -fiv must be
> run to regenerate configure, eliminating the changes made by the
> glibc-2.21 patch. Therefore, I need to know how to reorganize the page
> to accommodate the patch. I would like some kind of recommendation on
> how to restructure the page.

The real fix would be to patch configure.ac for the glibc-2.21 correction and 
then run autoreconf.  Since the linux_4.x_compilation_fix works on configure.ac, 
the glibc fixes could also be merged into a consolidated patch.

Do you need help doing that?

Also in the patches, do NOT use embedded tabs (in patches or anything else in 
BLFS). The valgrind-3.10.1-linux_4.x_compilation_fix-1.patch needs to be redone 
to remove them.

$ cat /etc/vimrc
" Begin /root/.vimrc

set nocompatible
set backspace=2
syntax on

set expandtab
set tabstop=3
set shiftwidth=3
set laststatus=2
...


If an existing file already has tabs in it, the command in vim is :retab 
assuming the above vimrc.


   -- Bruce



More information about the blfs-dev mailing list