[blfs-dev] MesaLib-10.4.3 make failed for libtool-2.4.2, solution is simple

Bruce Dubbs bruce.dubbs at gmail.com
Mon Jan 26 10:18:08 PST 2015


Fernando de Oliveira wrote:
> On 26-01-2015 13:53, Bruce Dubbs wrote:
>> Pierre Labastie wrote:
>>> Le 26/01/2015 15:47, Igor Živković a écrit :
>>>> On 01/26/2015 03:22 PM, Fernando de Oliveira wrote:
>>>>>
>>>>> If you agree with the modifications but doesn't want to do the commit
>>>>> yourself, I volunteer.
>>>>>
>>>>> While waiting for your (or anybody else's) reply, I will try the
>>>>> "autoreconf/configure" combination (thought about it when writing this
>>>>> post).
>>>>
>>>> I didn't run into this issue but then again I don't install LFS by the
>>>> book for a long time now. I trust you, Fernando, with making any
>>>> corrections necessary.
>>>>
>>> FWIW, I just built Mesalib-10.4.3, and everything went OK : I have a
>>> recent version of LFS (20150112), and the installed libtool is 2.4.4.
>>
>> My old -dev system has 2.4.2 and my new one 2.4.4, but I haven't build X
>> for the new system yet.  I can do that today if necessary and check
>> Mesalib instructions.  Do you need me to do that?
>
> I think both are amd64 systems, right? I don't know the architecture of
> Igor's and Pierre's systems. It could be interesting confirming or not
> that you have problem with the old system with 2.4.2, so we could be
> more specific in the Note. One more thing is that probably you are using
> GCC older than mine, there (?), mine is current 4.9.2.
>
> So, please, both tests would be much appreciated, but I believe you
> don't need to do it in the new machine without X yet, as they have
> already been done by Pierre and Igor.

OK, using the instructions in the book, I get:

make[4]: Entering directory '/tmp/mesalib/Mesa-10.4.3/src/util'
   CC       libmesautil_la-hash_table.lo
libtool: Version mismatch error.  This is libtool 2.4.4, but the
libtool: definition of this LT_INIT comes from libtool 2.4.2.
libtool: You should recreate aclocal.m4 with macros from libtool 2.4.4
libtool: and run autoconf again.
Makefile:634: recipe for target 'libmesautil_la-hash_table.lo' failed

If I change the instructions to:

autoreconf -fi &&
./configure  CFLAGS="-O2" ...

It builds fine.  I didn't install though.

gcc-4.9.1, libtool-2.4.2, lfs SVN-20140908, x86_64.  Do you need me to 
do a test build on a LFS-7.5 system also?

   -- Bruce


More information about the blfs-dev mailing list